openHABian v1.4 / v1.4.1 released!

It is weird, each time you type it, it looks as if it is was not saved.
You cannot edit it again, but it basically works.

I might discovered a new bug.
I’m currently learning myself to add Things, Items and Rules manually. Would just mention that i if i remove a “thing” from the “.things” file it still is present in PaperUI Things. I also tried removing the .things file entirely but no changes in the Paper UI.Same goes with the Habmin Things. If i reboot it all disappear but that’s probably not how its supposed to work i would assume?

@ThomDietrich - FANTASTIC UPDATE!

Ok only one issue I’ve run into … it seems my tiles have not updated with the FrontTail and Node tiles, even though I have them. I’m wondering if it has to do with the fact that I’ve already installed them, so OpenHABian isn’t installing them itself at this time. Aka, I upgraded from an older version. Not sure how you “track” which tiles to show?

I can attempt just going through the menus to install Node and FT again if that will trigger it?

The download link from bintray gives a forbidden message :frowning_face:

If i try to update the installed packages i see also a error 403 on the stable source in apt.

sudo apt-get update
[sudo] password for openhabian:
Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Ign:3 http://repos.azulsystems.com/debian stable InRelease
Hit:4 http://repos.azulsystems.com/debian stable Release
Ign:5 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Err:6 https://dl.bintray.com/openhab/apt-repo2 stable Release
403 Forbidden
Reading package lists… Done
E: The repository ‘https://dl.bintray.com/openhab/apt-repo2 stable Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Hallo, same here, can you please add some dll mirror?
Thanks & enjoy 2018! :]

I can’t get the image downloaded: I get 403 forbidden

I cant install:
2017-12-31_15:42:27_CET [openHABian] Installing or upgrading to latest openHAB release (stable)… FAILED (apt)

The link is working again. Thanks!

thx!

Hi,

i have some issues with homegear. I prepared a new SD with the openhabian 1.4 image and install homegear. All works perfect. Yesterday i want update the system. i used the openhabian-config tool. After that, my homegear is broken.

if i want start the service, i get the following error:

Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Unit entered failed state.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Failed with result 'exit-code'.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Service hold-off time over, scheduling restart.
Jan 02 16:16:24 openHABianPi systemd[1]: Stopped Homegear.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Start request repeated too quickly.
Jan 02 16:16:24 openHABianPi systemd[1]: Failed to start Homegear.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Unit entered failed state.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Failed with result 'exit-code'.

journalctl -xe shows me the following:

Jan 02 16:16:24 openHABianPi systemd[1]: Starting Homegear...
-- Subject: Unit homegear.service has begun start-up
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit homegear.service has begun starting up.
Jan 02 16:16:24 openHABianPi homegear-start.sh[1838]: /usr/bin/homegear: symbol lookup error: /usr/bin/homegear: undefined symbol: _ZN7BaseLib15HelperFunctions9splitLastENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEc
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Control process exited, code=exited status=127
Jan 02 16:16:24 openHABianPi systemd[1]: Failed to start Homegear.
-- Subject: Unit homegear.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit homegear.service has failed.
--
-- The result is failed.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Unit entered failed state.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Failed with result 'exit-code'.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Service hold-off time over, scheduling restart.
Jan 02 16:16:24 openHABianPi systemd[1]: Stopped Homegear.
-- Subject: Unit homegear.service has finished shutting down
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit homegear.service has finished shutting down.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Start request repeated too quickly.
Jan 02 16:16:24 openHABianPi systemd[1]: Failed to start Homegear.
-- Subject: Unit homegear.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit homegear.service has failed.
--
-- The result is failed.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Unit entered failed state.
Jan 02 16:16:24 openHABianPi systemd[1]: homegear.service: Failed with result 'exit-code'.
Jan 02 16:17:01 openHABianPi CRON[1979]: pam_unix(cron:session): session opened for user root by (uid=0)
Jan 02 16:17:01 openHABianPi CRON[1983]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Jan 02 16:17:01 openHABianPi CRON[1979]: pam_unix(cron:session): session closed for user root

Before i do the update, it works fine. Now i have deleted homegear and re installed it, but i get this error everytime. I hope you can help me :confused:

Well, apparently there’s a problem with the most current version of one of the homegear packages. openhabian doesn’t include them but just retrieves these from the repository (see /etc/apt/sources.list.d/homegear.list).
So for the time being, you would need to ask the homegear maintainers.

@ThomDietrich…awesome job! id like to suggest an addition…menu item to set a static ip to the pi…why? why not! you have everything else…

1 Like

@ThomDietrich, thanks for the SD image. I was able to install everything from SD, it was ok, then, I tried to copy the image with Etcher to a SSD drive and was able following the steps I descibed there OpenHAB2 on separate USB (Raspberry Pi) to boot from my SSD drive and install openHab2 on the disk. But was not able to reproduce it after shut down a second time. So the question is (dummy…) do I have to boot with the SD card, but what datas should be on the SD? should the bootcode.bin file still be there? I’ve tried but have only the colorized start screen…
Thanks, Chris

Would it be possible to implement reboot system and restart OH2 buttons into openhabianpi:8080/start/index page?
Would love to have those features! Could be a optional installation package through the openhabian-config for example.

3 Likes

I like this Idea! A restart button in sitemap would be great!

Holger

No. You shouldn’t need to be restarting OH. Once setup correctly, it is supposed to run 24x7.
Anyone who still wants to restart OH or boot his box can do so from the shell level (or simply by powercycling).
If your OH does not work, you are asked to help finding out why it does not (open a GitHub issue, gather and upload logs).
I definitely wouldn’t want to encourage more people to unnecessarily restart OH or even boot their boxes by adding this in openHABian.

3 Likes

Yes, I agree, if the system is stable and has no bugs.
But there are issues like posted here, which currently require restarts:

It can be done on the console, yes, but it would be easier to do this with a button. Only my 2ct.

Holger

1 Like

Edit: Created a new topic.

@ThomDietrich, possible or not to install from external mSATA USB? please look there my config and my error logs, thanks [openHabian] Cloning myself... FAILED