openHABian hassle-free openHAB Setup

It would make more sense to use the Raspbian version provided by Raspberry Pi and then install whatever version of OpenHABian you desire.
The work required for the image would be OS related, not OpenHABian related.
Many people are running 2.5M Milestone release. I am currently running a snapshot.
2.5 will not be released this month due to all the work required.

+1 for that!
RPi 4 (that needs Raspbian Buster) with the 4GB memory would be perfect if you want to include multiple video streams that are CPU/MEM heavy!

Debian Buster has a release date of July 6. Will Raspbian be ready on the same date?

The Raspbian image for RPi 4 is already built from Buster.

openHABian v1.5

We have a new version featuring RPi 4 support and based on Rasbian Buster.
Have a look and enjoy :rocket:



11 posts were merged into an existing topic: /var/lib/openhab2 gone

11 posts were split to a new topic: /var/lib/openhab2 gone

It´s currently not possible to install zram beta from the openhabian-config.
The log says that the repository from @mstormi can´t be found.

2019-09-12_12:44:00_CEST [openHABian] Checking for changes in origin... OK
Username for '': ***
Password for 'https://***': 
remote: Repository not found.
fatal: repository '' not found
/bin/sh: 0: Can't open ./
Failed to start zram-config.service: Unit zram-config.service not found.

Checking the website in my browser gives the same result: 404

kind regards

It’s been moved:

Maybe not moved but is available at the link in that post

1 Like

I’m waiting for that repo to be transferred to me which is why I had to delete mine first.

Thanks for the hint!
I solved the issue by editing the zram.bash in opt/openhabian/functions

Changed the following lines:

    local ZRAMGIT=
    local TAG=master

Hi, I wanted to know if this last image is supported by RPi3. Or does it only work with RPi4?

It’ll work on any RPi 2/3/4, see new README.

Thank you so much!

I bought a raspberry pi4 and I can’t install the latest version of openhabian 1.5 with the last image file.
I think it’s a java problem.
Can you help me?

I am testing Openhab on Raspberry Pi using Openhabian. every time the device Pi is turn off and on it should go trough the process of installing everything? or after first boot and set-up it should go directly to start Openhab?


Is the openhabian 1.4 version on rsp pi3b still working? Clearly on the stable openhab version 2.4.

it’s one time installation script and start only at first boot

Nope, you have to wait a new build because a thirth part link it’s changed. OR you could install actual 1.5 and manually modify the link (you should find a lot of thread on the forum)

Unfortunately the 1.5 I was not able to install it neither with the rasp p3 than with the p4. Unfortunately I got stuck !!! With the previous versions everything was ok now I can’t install openhabian anymore and so I got stuck. Help !!

Ok I solved it.
I replaced the micro sd it worked.