openHABian hassle-free openHAB Setup

Nice. Good luck!
While you are at it, would you be interested in also helping to get the wifi-only setup running? This should be possible by simply putting a wpa_supplicant.conf in the config folder of your SD card, but @Vincent didn’t have much success trying this :-/

Edit: Only if “upgrading” includes a reinstall, which, as I recall, was not your intention…

Yes, by “upgrading” I really meant complete reinstall.

I’ll have a look and see what I can do. My cable connection far “out-speeds” my WiFi connection, however, so I have a feeling I would rather like to do the download on the cable connection, :slight_smile:

Trying to use openhabian with a Razberry. I can not get the port dev/ttyAMA0 to be recognized in Openhab. Anyone had any luck with openhabian and Razberry?

Hey @Skalleno, could you reveal a few more details? I do not own a Razberry but from what I know, you need to first switch ttyAMA0 from serial port to peripheral mode. This can be either done though configuration files or raspi-config. Any luck with this?

Please let us know if you where successful, I’ll probably make this a default for openHABian.

Tried to change the setting in raspi-config, but no luck. Z-Wave serial controller has yhe following error: Serial Error: Port dev/ttyAMA0 does not exist, in earlier openhab versions i think you had to add the serial port to Can not find that here.
The port does show up when running this command ls -la /dev/ttyAMA0.

Related to OpenHAB2 + Razberry + Z-Wave Binding ?

Added users pi, tty ,root and openhab to the dialout group. Added" to /usr/share/openhab2/runtime/karaf/bin/setenv Z-Wave serial still has the same error: Port dev/ttyAMA0 does not exist

Did you make sure the serial port is not active? If it is indeed still active this should be changed first. If method 1 didn’t change anything, try with method 2 or with the most direct way, method 3.

Yes it is disabled: “Serial console on /dev/ttyAMA0 is disabled” Can it be some kind of permission issue?

I went through the steps myself and while disabling the serial interface via raspi-config doesn’t change anything, method 2 (this script) got the job done and presented the message you quoted.

Please ask for further help in the other thread related to that problem.

What you probably wanted to do is add user “openhab” to group “tty”!?

sudo adduser openhab dialout
sudo adduser openhab tty

Edit: /dev/ttyAMA0 doesn’t exist anymore…

That’s probably something you want to fix. --> first answer. This was tested by me to have the effect you want.

[15:25:36] pi@openHABianPi:~$ cat /boot/config.txt
initramfs initrd.img-4.4.0-1-rpi followkernel
# to disable DeviceTree, uncomment the next line
[15:25:54] pi@openHABianPi:~$ cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=tty1 elevator=deadline net.ifnames=0 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait
[15:26:03] pi@openHABianPi:~$ ls /dev/ttyAMA0
[15:26:11] pi@openHABianPi:~$ cat /proc/cmdline | grep AMA0
[15:26:14] pi@openHABianPi:~$

1 Like

Did edit config.txt and cmdline.txt. This is what i got now, but still comes up as /dev/ttyAMA0 does not exist

That’s as far as I can help. Now you indeed need to continue in the other thread… Good luck

Great helpful tool!!!
Thanks a lot! It saved a lot of time for me.

However I do not see the folder /usr/share/openhab2/conf, but just /etc/openhab.
Usually there is a link from /usr/share/openhab to /etc.
Especially because the official website of OH2 mentions “configurations” was renamed to conf
I am confused.

And another point:
Where are the addons located?
They are not in /usr/share/openhab2/addons…

Hey @NCO, great it worked out so far :wink:
All your questions are related to the different ways of setting up openHAB (2). It is favorable to set up using the official openHAB2 package repository. With this installation method, your files are a bit scattered on your filesystem, described here.
As you can see, your configuration is supposed to be under /etc/openhab2 and the addons folder can be found under /usr/share/openhab2/addons.

The mentioned paths and for example the link to /etc are actually not standard. openHABian follows the official installation instructions linked above.

I’m in the process of improving the documentation, could you show me where the mentioning of “configuration” was confusing?

Btw regarding bindings, you only need the addons folder if you have an addon you know is not part of the distribution. All existing ones can be found:

ll /usr/share/openhab2/runtime/karaf/system/org/eclipse/smarthome/binding
ll /usr/share/openhab2/runtime/karaf/system/org/openhab/binding

and so on.

Hi @ThomDietrich,

thanks for your extremely quick response. :slight_smile:
Your points above solved my confusion, which was actually not related to your openhabian, but the official website of OH2.
I was not aware that package repository folders are different to the manual installation.
Again, thanks. I might come back with other questions.
Anyway - a great help from your side switching over to OH2!!

1 Like

I’m very very tempted to give my Pi3 a refresh with this image. Thanks for all the effort with it.

This may or may not help with installing Go, but perhaps installing Docker first, and then Go/Influx/Grafana?


I was not able to spend a lot of time on this over the weekend (the weather was simply to nice!) but here is what I have done so far:

  1. Upgraded my system (RPI3) with a clean install using OpenHABian v0.9.
  • I tried to add the wpa_supplicant.conf file - with content matching my WiFi setup - but no success.
  • The green led was flashing steadily (on/off at ~1 Hz) and the RPI was never registered on my WiFi AP.
  • I then removed the file, and connected the Ethernet cable.
  • Some time later (after watching a movie) the system was installed and running.
  1. Downloaded the standalone ARM binaries for InfluxDB and fired it up. Seems to work OK (at least the system is reported as running, and the web interface is responsive).
  • I have not yet figured out where to put the various files - binaries and configuration - and how to make it start as a service.

hello tried your package and all went fine. problem im having is my zstick, which is normally on port ACM0 is not recognized as a valid port. Any ideas?