openHABian hassle-free openHAB Setup

Thank you, got it working using about the same as you wrote.

Well, slight progress. I redid Samba via the new OpenHABian menu. I now have write access to my .items and .sitemap file. The problem is that in Designer, I can only see those files when I click on the individual “Items” and “Sitemaps” folder. they don’t populate when I click on the “OpenHAB-Conf” folder.

I know this situation has been discussed before but for the life of me I can’t find the thread that discusses this. Any idea?

First part sounds good, can you post a screenshot of how your designer looks like when you select the config folder?

Can you please post the exact error description? Is this related to the demo package? There was a change regarding the doorbell.mp3 the other day.

I guess this should be possible. openHABian is based on raspbian-ua-netinst and it provides this option:
usbroot= # set to 1 to install to first USB disk
Let us know if installation was successful this way.

As you were talking about the demo package, it just came to my mind that there was another “unusual” log entry. Some kind of “installation of standard package” error.

But again, I’m sorry that I can’t be of any further help because I haven’t saved the log and have overwritten the SD card,

I will later, but really it is blank. Nothing shows up. I have to select the Items folder to see the .items files, Sitemaps folder to see the .sitemap files, ect.

Are you trying to open the network share or a drive the network share is mounted on? I don’t know if the first is even possible but the second is how it should and I do not see why not… :confused:

I’m away from my computer right now but when I select the openHAB-conf folder I should see all the .item, .persist, .sitemap files contained in all the sub folders in the panel in the upper left. At least I did on my OH1 setup. Right now I get nothing. I only see the files if I select their respective folders.

Hi @ThomDietrich: I’ve had the chance to do another openhabian installation. Same result. A ton of Javasound errors and also the mentioned package error. But this time I was smart enough to get the log files.

raspbian-ua-netinst.log.xml (55.9 KB)
openhab.log.xml (86.1 KB)

This is the log from a fresh installation (current version 0.9) on a RPi3. Waited until the steady heartbeat. OpenHAB is nevertheless running, I can connect via SSH and Webfrontend is also accessible. The main part of the error messages is about java sound, somewhere around the middle of the log you can also find the mentioned package error:

Failed installing ‘openhab-package-standard’: Error restarting bundles

Any help is appreciated!

Thanks,
Stefan

Ah I see. @Kai do you know that problem?

java.lang.RuntimeException: Error creating the AudioSource
...

Caused by: java.lang.IllegalArgumentException: No line matching interface TargetDataLine supporting format PCM_SIGNED 16000.0 Hz, 16 bit, mono, 2 bytes/frame, little-endian is supported.
...

2016-10-05 17:43:46.548 [ERROR] [org.eclipse.smarthome.io.javasound  ] - [org.eclipse.smarthome.io.javasoundsource(11)] Failed creating the component instance; see log for reason
2016-10-05 17:44:02.717 [ERROR] [org.eclipse.smarthome.io.javasound  ] - [org.eclipse.smarthome.io.javasoundsource(11)] Error during instantiation of the implementation object

Yep, they’re the same ones i’m seeing in both the daily’s .deb file install and openhabian.

checked the documentation there … USB seems to work … not Raid 1 :frowning:

already had a sd card and usb stick with OH2 that failed probably due to write cycles… redundancy by a raid1 would be perfect imho

Here you go Thom. As you can see, nothing to see. This is when selecting the OpenHab-conf folder. The same thing happens with OpenHab-userdata folder.

Are you running as an administrator in windows? I couldn’t get the conf folders loaded until doing so.

Just tried doing that… still nothing. :confused:

Because you are talking about folders again… I have to ask again. Did you mount the shares as drives in Windows?

Question does this openhabian image have the addons folder for adding older binding jar files like the plex binding. I had this working on openhab2 in windows like a charm but I dont see the addons folder in this image.

Yes, answered in an earlier comment.

Ah so basically i need to just share out /usr/share/openhab2/addons to be able to drop the files in there. Still trying to figure out Linux commands for doing everything.