openHABian hassle-free openHAB Setup

Currently there are only two shares when I try to browse to the ip from a Windows PC. But based on the documentation it should already be shared out correct?

Mine wasn’t. I had to add the share to the bottom of the smb.conf file via sudo nano /etc/samba/smb.conf

Reported here:
Will work on it today!


How would you access the client console of openhabian? I’m using a Windows machine with putty to get ssh access. I want to be able to look at my items and see the running live running log of what the server is doing.

Im guessing you mean openhabs console? Whilst you’re in putty connected to your pi, you can type the command ssh openhab@localhost -p 8101. The password of which is ‘habopen’.

The commands you’re after are items or log:tail, you can stop the log tailing with ctrl+c

1 Like

Sorry, I’m not the most knowledgeable when it comes to computers (hence loving openHABian). I was under the impression that mapping a drive and mounting a drive was the same thing.

I’ll work on it a bit more and let you know.

That worked! Thanks for the tip!

That’s right. This actually already prepared but commented out. I have just changed that in openHABian (untested). Please update your local openHABian and then redo the Samba setup:

sudo openhabian-config
# select update (first option)
# will finish back on the console

sudo openhabian-config
# select option "Samba"

After that, the new additional share should be available.

I’m not sure what’s the one and the other. Can you follow this or a similar tutorial to get your “openHAB-conf” mounted as e.g. drive letter “O:”

Adding to @Benjy 's answer, this and all further details can be found in the docs:

You can additionally open the Console to be accessed from your local PC directly: openHABian hassle-free openHAB Setup

In order to just look at the log, including events.log, it’s actually easier to use the command


Short update: I did a few changes yesterday. This is not a new version yet.

openHABian now includes avahi-daemon as part of the basic setup, making discovery on your local net easier. (Thanks to bodiroga)

Added assisted Wifi setup for the RPi3 (Thanks to @Vincent)

@KjetilA @fg2it InfluxDB and Grafana are now selectable to be installed on the RPi2/3. Thanks to fg2it for his prebuild and the repository. Next I’ll automate most of what was written in the InfluxDB+Grafana tutorial to get the users and the connections between the two components and openHAB work out of the box.

It would be great if you could give these new options a try.

Still missing: For the v1.0 release I’m mostly missing documentation, both in openhabian-config and on That’s something I’ll just have to do. If you want to help, you are more than welcome to help improve the code and to add optional components.

How specific is this to the RPi? I am going to be rebuilding my Pine64 (Ubunutu). Do you think it will it take much to port this over to another Linux OS?

Not at all. I’m in the process of making that clear in documentation: openHABian is (1) an image for the Raspberry Pi and (2) the script collection inside it which can be used on other Debian/Ubuntu based systems.

So yes, you should be able to use openHABian on your Pine64. After installing your base system, here is what you need to do:

# install git
sudo apt-get update
sudo apt-get install git

# get openHABian
cd /opt
sudo git clone
cd openhabian

# Execute as root
sudo /opt/openhabian/

In the menu presented, just execute the first few steps. let me know of any errors presented in the console. If you see a problem, please let me know so I can fix it in the script.

Is there a place that we can dump images for a sitemap to use on the os?.. I’m using the rotini app and it has the ability to use images as backdrops in the app but it needs a URL to the jpg file.

Yes. all files placed in /etc/openhab2/html/ can later be served under http://your-openhab-device:8080/static/image.png for example. Please ask this kind of general openHAB questions in the forum, rather than in this openHABian thread. :slight_smile:

1 Like

Great thanks!.. Sorry wasnt sure if that was something that was specific to openhab or the openhabian image its self.

Hi ThomDietrich,
Again, my thanks for this image. It makes the installation so much easier for the NOOBs. I have been running on your image for some months now and everything is working very well for me.
Since the beginning (even before openHABian), I have always had problems with the RPi GPIO access from OH2 on Jessie. I have tried everything and keep having issues. I have again tried to follow the links you posted earlier, but keep running into errors… I guess the wiki refers to OH1 and not OH2 or Jesse. I am obviously doing something wrong. Can I please ask you to add this functionality to your image or to help with a line for line example?

The GPIO binding is 1.9 so the wiki is the correct place for documentation for how to configure and use it.

I see nothing in the documentation to indicate that there is anything special or different about Jessie.

Hi ThomDietrich –

I’ve been working on getting a clean install of OpenHAB for a while now (in the precious little spare time I have, and the even less linux knowledge), so I was really excited to come across the image you’ve created! Since I had nothing worth saving, I reimaged my SD card and kicked off the installation last night. When I came back about 4 hours later, it appeared to be done – heartbeat green lights and your banner on the screen. The first thing I tried to do was connect to the UI, but unfortunately I’m getting “Access Denied” when I go to from my browser. So – stupid question time – do I access from a browser on the Pi, or should I be able to get to it from another machine on the same subnet (I am able to ping the Pi from the other computer)? If I need to do it from a browser on the Pi, how do I get into a GUI to run a browser? I read an earlier post where someone was having a similar problem and updating openhab2-offline fixed it. When I do an update/upgrade it tells me that openhab2-offline is the only package needing an upgrade, and it seems to do it without error, but it doesn’t fix my problem, AND if I repeat the update/upgrade it tells me that openhab2-offline still needs to be upgraded. Any help you can offer would be great!

@Jeffl This isn’t openHABian specific, but are you sure that you’ve got the right ip address for the Pi? It should be visible at that address on any machine on the same local network.

Thanks for responding Paul. Pretty sure - I’m able to ping that IP address
and SSH into it from the other machine. It almost seems like an access
rights issue. The error I get is “Refused to Connect”. If I put in some
other random IP on the same subnet I get “Site is Unreachable”.

Are you certain that OH is actually running? Connection Refused can mean that there is nothing listening on that port.