openHABian hassle-free openHAB Setup

Looks like the cloudbees build of the latest snapshot failed, and only one version is possible at the moment. Might need to bare with us just a bit longer.

looks like it´s still broken :frowning: not so “hassle-free” soluation trying since hours.
the generic linux install process http://docs.openhab.org/installation/linux.html has same same issue. package list not available…

Err https://openhab.ci.cloudbees.com  Packages                                                                          
  HttpError404
Get:49 https://openhab.ci.cloudbees.com  Translation-en_US [366 B]                                                      
Ign https://openhab.ci.cloudbees.com  Translation-en_US                                                                 
Get:50 https://openhab.ci.cloudbees.com  Translation-en [363 B]                                                         
Ign https://openhab.ci.cloudbees.com  Translation-en                                                                    
Get:51 https://openhab.ci.cloudbees.com  Translation-en_US.UTF-8 [372 B]                                                
Ign https://openhab.ci.cloudbees.com  Translation-en_US.UTF-8                                                           
Fetched 9,106 kB in 17s (511 kB/s)                                                                                      
W: Failed to fetch https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo/Packages  HttpError404
W: Failed to fetch https://openhab.ci.cloudbees.com

is there an option to get manual install package?
this should be improved some way in the future, because build will fail form time to time

Yes, the last build (#695) was made on 05.01.2017 16:47 and was broken. Since then no new build was made. I don’t know about the mechanisms for creating a new build. Maybe it has to be manually triggered, maybe it automatically tries again in case of a failed build.

You can use the manual installation method described on the link you posted. The zip-file of the latest successful build is available. But I would suggest to wait until the next successful build to start again using the package repository. It’s making things easier in the future (updates etc.).

And just for clarification: This is not the fault of openHABian.

Before finding this thread I created a ticket: https://github.com/openhab/openhabian/issues/67
I posted there instructions to install the packages. But I agree with jaydee73 that to ease future updates waiting for a fixed build could be a good idea. You can observe the status of the builds here: https://openhab.ci.cloudbees.com/job/openHAB-Distribution/
Hassle-free installation will work once the latest build has a green light.

My installation of Openhabian was successful this afternoon since build #696 was successful. However, i would agree that it would be helpful if there is some way to prevent the failure by using the most recent successful build or to describe the reason for the failure. Granted, i am very very new to openhabian but if it is possible to know that it will fail because of a dependency prior to running a fresh install, it would be helpful to save users time and potential frustration.

I have a question regarding the domain setup. Is it also possible to automatically configure a dyndns deamon to keep a dynamic IP address up to date?

Why would you do that if there is a openHAB Cloud connector available?:

http://docs.openhab.org/addons/io/openhabcloud/readme.html

I prefer to use my own domain and be independent of external cloud services :slight_smile:

1 Like

okay, valid reason :grinning:

Hey guys, I’ve been absent for a few days. Let’s see what’s going on here :slight_smile:

@GlidingFool great the upgrade worked for you. The provision of sudo openhabian-config is something done in another part of the script, which was not part of the older openHABian build you are using. I’ve added fixing this to my TODO list.

@madeinnorte GPIO is something discussed here. I’ve not spent much time on that problem. You could consider using the exec binding in combination with pigpio. Please consider taking part in the conversation in the thread!

@madeinnorte “I can not run the Wifi.”?

@stdll Nice you got it working. Thanks @jaydee73. Same goes for @wender_reis, @ElGustaff and @Jansen.
I should add, that you do not need to panic about that!

  1. this was an unfortunate time, a failed openHAB build to be present for long is not common. As @Anttisep said it would have been best to wait for the next build. I get that that’s not easy if you are on a tinkering spree :smiley:
  2. with the new repository just released, a failed build will not delete the last working build (@Paul_Morley). @Benjy are you able to confirm that!?

@djkevinz Great to hear! :wink:

@Dome I can’t help you with your USB sound card. However, you may be interested in this change: https://github.com/openhab/openhabian/issues/40 - maybe you need to remove the added option (dtparam=audio=on).

@tobias I understand your reasoning. I’m using my own domain as well. @sihui I love to be able to access my home via https://street-number.myhometown.de :wink: Regarding your question @tobias, check your router for an option to do that for you, otherwise check out ddclient and/or look for tutorials for your dyndns provider, e.g. http://www.noip.com/support/knowledgebase/installing-the-linux-dynamic-update-client

Hi
i can confirm - this time installation went fine :slight_smile: I got no error messages and logged in to opehabian:

              Welcome to            __  _____    ____  _
            ____  ____  ___  ____  / / / /   |  / __ )(_)___ _____
           / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  / / __ `/ __ \
          / /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ / / /_/ / / / /
          \____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/_/\__,_/_/ /_/
              /_/
                       openHAB 2.0.0~20170108164202 (Build )

Thanks!

Yep! The bintray builds should be triggered only when a new build succeeds.

1 Like

Will you update the apt sources for the new repository automatically with openhabian-config or better do it manually on our own?

Hey @skeal and everyone else,
I’ll implement the needed changes this evening and come back to you :wink:

@ElGustaff I’m a bit confused about the absence of a build number. Is “(build )” really what you see?

1 Like

Hi
Seems like i didn’t copied everything from the terminal. The correct output for “buid” is
Build #701:

openHAB 2.0.0~20170108164202 (Build #701)

The other question - does openhabian requires some changes in smb.conf file for guest user? I’m not able to save changes in configuration files when i’m mountng smb share for “guest” user (for some reason i can’t mount the share using user “pi”)

As a “guest user”? I don’t know what you mean by that. Pay attention to the first posting:

Hi all,

Once again @ThomDietrich for your efforts in making the setup such a breeze!

When I reboot my pi I need to enter the username and password in order for OH2 to start. After a power failure it would be useful if OH2 could start without entering these credentials when the Pi itself boots.

So my two questions are:

  1. Where do I set it so that there is no bootup password?
  2. Is this unwise?

Apologies if this was asked elsewhere but I couldn’t find an answer.

Craig

This shouldn’t be necessary at all. Of course you have to enter it when you log in via ssh. But with openhabian (using the apt-get method), openHAB is configured as a service, so will be started automatically during boot.

Do you only need to enter the credentials in case of a power failure (therefore a “hard” crash), or also when you do a controlled shutdown and reboot?

1 Like

Hi all,

i tried to set up openHABian several times today, but it doesn´t work. It looks like there is a problem fetching the snapshot files. There is always a 404 error. When opening the URL in a browser the whole path is missing. Is there again a problem with the build?

Hello @ast, this is related to the following change and I just this second did the needed changes to openHABian. Please restart the installation and everything should be fine.

Restart:

sudo mv /boot/config-reinstall.txt /boot/config.txt
sudo reboot