openHABian hassle-free openHAB Setup

openHAB 2 new apt repository and the single distro refactor

Everyone, another important change to openHAB 2 before it’s final release has happened. For one are packages now hosted by a new more powerful repository service provider and secondly are the packages openhab2-online and openhab2-offline now replaced by a base openhab2 package and a openhab2-addons to install on top. Find more details in the corresponding announcement threads:

Implications for openHABian users

I’ve done the needed changes to the openHABian scripts. From this point on forward openHABian will default to openhab2 (the previously known “openhab2-online” package). An option to easily select the addons package will follow.

Fresh installations: The openhab2 package will be installed on fresh systems. Nothing to pay attention to there.

Existing setups: If you are already using openHABian, just execute sudo openhabian-config, then select “Update” followed by “openHAB 2”. This will transition your setup over from the cloudbees repository to bintray and from openhab2-offline to openhab2. You will be prompted about 1-2 changed files in /var/lib/openhab2/etc. Select “Yes” to have them overwritten. Give openHAB a few minutes to restart, you may have to trigger another restart by typing sudo systemctl restart openhab2.service, after that your system as you know it will be back on track. Remember to backup your configuration.


Thank you. Not sure how it would all tie in together philosophy wise, but I believe OpenHabian should be promoted by OpenHab as the main install method. Of course, manual installs would be available for the more “advanced” user.

The work you’ve done has saved hundreds, if not thousands, of man-hours for new users. I can only imagine what the percentage is of people who attempt a manual install and give up, swearing off the platform. I can easily see a 50% or greater increase of users based on this service alone.


That actually fixed my sound issue - thanks!

1 Like

Thanks @RHINESEL, always nice to get feedback from you! :wink:
I’ve actually already “sneaked” openHABian into that position by mentioning it here a couple of times :smiley: However, do not forget, that there are many different platforms and operation systems you can run openHAB on. Using openHABian on a Raspberry Pi is only one way and not fitting for everyone. Still feel the same way as you. For newcomers a Raspberry Pi plus openHABian might be the smoothest openHAB experience you can get. Maybe @Kai want’s to suggest that in the big openHAB 2.0 annoucement :slight_smile:

@Dome well, what a coincidence :wink:

Yeah, I still need to file a bug report that I cannot get openHABian running on my Mac mini! :innocent:

I’ll make sure to mention it - but only if is filled with decent content until then :slight_smile:


Extortion! :smiley: Yeah that’s on my TODO list :disappointed:

Only debian based systems, sorry. You could install Debian on your mac though :stuck_out_tongue_winking_eye:


did a update / upgrade this eve and didnt get the newest with kodi binding that kai mentioned was in the newest release. What do I need to do?

Please first check which build you are on. Compare with the following to know if you are on the latest.

I have just tried to update and get these errors:

2017-01-11 13:05:19.664 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'house.items'
2017-01-11 13:05:20.367 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'rrd4j.persist'
2017-01-11 13:05:20.435 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'mapdb.persist'
2017-01-11 13:05:23.383 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'house.rules'
2017-01-11 13:05:23.828 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'timeField.rules'
2017-01-11 13:05:25.508 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'house.sitemap'
2017-01-11 13:05:27.899 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
2017-01-11 13:05:30.063 [WARN ] [url.mvn.internal.AetherBasedResolver] - Error resolving artifact org.openhab.ui:org.openhab.ui.habpanel:jar:2.0.0-SNAPSHOT: [Could not find artifact org.openhab.ui:org.openhab.ui.habpanel:jar:2.0.0-SNAPSHOT] Error resolving artifact org.openhab.ui:org.openhab.ui.habpanel:jar:2.0.0-SNAPSHOT: [Could not find artifact org.openhab.ui:org.openhab.ui.habpanel:jar:2.0.0-SNAPSHOT]
	at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve([7:org.ops4j.pax.url.mvn:2.5.2]
	at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve([7:org.ops4j.pax.url.mvn:2.5.2]
	at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve([7:org.ops4j.pax.url.mvn:2.5.2]
	at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve([7:org.ops4j.pax.url.mvn:2.5.2]
	at java.util.concurrent.Executors$[:1.8.0_111]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201([:1.8.0_111]
	at java.util.concurrent.ScheduledThreadPoolExecutor$[:1.8.0_111]
	at java.util.concurrent.ThreadPoolExecutor.runWorker([:1.8.0_111]
	at java.util.concurrent.ThreadPoolExecutor$[:1.8.0_111]
Caused by: Error resolving artifact org.openhab.ui:org.openhab.ui.habpanel:jar:2.0.0-SNAPSHOT
	at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve([7:org.ops4j.pax.url.mvn:2.5.2]
	... 12 more
2017-01-11 13:05:30.103 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-persistence-mapdb, openhab-binding-yahooweather, openhab-persistence-rrd4j, openhab-ui-basic, openhab-misc-restdocs, openhab-misc-openhabcloud, openhab-binding-astro, openhab-ui-habmin, openhab-ui-habpanel, openhab-ui-paper, openhab-binding-zwave': Error

The UI says Please stand by while UIs are being installed. This can take several minutes.
but I’ve waited a while now.

Can anyone help?

I didn’t see this myself, upgrading two systems with different setups but there was another user with the same problem. For a quick solution see:

Remember to make a backup of your configuration and userdata beforehand.

i wont be in front of a computer to access to check until later today, but will do it…is there a possibility of adding a backup / restore feature to openhabian-config? would just add to the great work you’ve already done.

Totally. It would do more or less what you can find behind the link, plus some menu logic to present some hints and give the user a selection of which backup to restore. I’ll just have to find the time for that. Please create an issue referencing your message:

Thank you. An install of the addons did the trick.

that too will have to wait until im in front of a computer, cant sign up for a github account on my phone.

Hi @ThomDietrich, I am currently on build #710 (did the repository switch already using openhabian-config “Update & Openhab2” option). Today I wanted to check if there is an update available. According to your link to the Bintray releases this should be the latest release:

2.0.0~20170110001819 (Jan 09, 2017)

My release #710 is this one:

2.0.0~20170108170225 (Jan 08, 2017)

Problem is: I have tried apt-get update && upgrade and also openhabian-config with option “Openhab2”. But neither command got me the desired update. It seems that the update process doesn’t “see” the newer version.

Any ideas?

Hey @jaydee73, you found an actual bug there :slight_smile: Your openHAB release is fine, openHABian is presenting the latest openhab2-offline package version installed on your system. Let me fix that.

Hi Stefan,

Apologies for my late response. You are 100% correct, the service runs even after a hard crash. I’ve tested it and it starts perfectly.


Hello everybody,
The image project is really great.
I would like to use the homematic module “HM-MOD-RPI-PCB” with homegear.
I have already tried a lot but it does not run.
Is this supported or can someone help?


Hey @space4u, I am a Homematic user myself. I’m using a busware SCC to interface with homegear though. I totally think that should be possible. You will need to go three steps I believe:

@jaydee73 it’s fixed. As always, please run Update+BasicSetup :wink:

Hi @space4u, I’m quite new with very little experience with my own HM-MOD-RPI-PCB. But I read several times that there might be an issue together with the onboard bluetooth if you are running it on a Pi3.

1 Like