openHABian hassle-free openHAB Setup

Have you updated to the latest openhabian version? There was a change of the repo last week. It’s not Bintray anymore. Maybe your apt-get still tries to get the build from bintray?

What need to be set to get nightly builds. Thought only release can be run.

Maybe I got a little bit confused because of the expression “nightly builds”.

Openhabian only uses the stable version at the moment. And the stable version is still hosted on Bintray. Only the unstable version (nightly build, snaphsot version, however it is called…) is now hosted elswere, see here:

You can’t switch from stable to snapshot within openhabian. I think ThomDietrich wants to add this in the future, but atm this isn’t possible.

Hi everyone! I have installed the latest openhabian image on my RPI 3 (openhabianpi-ua-netinst-20170218-git11d8ebc.img). Afterwards I tried to put a binding into addons folder via samba network share (\OPENHABIANPI\openHAB-sys\addons), but it tells me that I don’t have to required permissions to do this.

Can anyone help me?

@pahansen @jaydee73 @lukics please check the docs more :wink:

2 Likes

Thanks @ThomDietrich and @jaydee73 much better now. Goes to show a lot can change around here in a couple of weeks when you’re not actively tinkering!

1 Like

For anyone having problems getting WiFi to work, make sure you only use a 2.4GHz SSID, and not a 5GHz one. Took me a while to figure this one out.

1 Like

I hope that’s a good sign :wink:

With the latest build of openhabian it is not possible to update to the latest kernel (rpi-update)
Is this a bug, that is already known?

I can confirm this. For rpi-update a package (binutils) needs now to be installed first. However when I did and ran rpi-update, the update bricked my installation (Pi3)…

Hi @ThomDietrich
With my RPi3 I did a new openhabian 1.1 installation last week.
Today I tried to continue with setting up my raZberry board.

Now I also have the problem like @sptzdmnc and @syrenius

  1. With sudo openhabian-config I prepared the Serial Port:

  1. When I tried to do sudo rpi-update I got the message to do sudo apt-get install binutils:

  2. So I did sudo apt-get install binutils

  3. After that I did sudo rpi-update again

  4. At least I did a reboot

  5. Now I can’t access the RPi anymore.

Is there a solution for this problem?

In the meantime I have also tried what @anfaenger has desacribed on a Raspberry Pi 2 to get a Razberry board running (fresh install). Exactly the same result.
If I do not do rpi-update, only the prepare serial dialog within openhabian-config, I am constantly getting a
OFFLINE - COMMUNICATION_ERROR Serial Error: Port /dev/ttyAMA0 does not exist
in PaperUI…

1 Like

@sptzdmnc @syrenius @anfaenger thanks for reporting this issue. This is a major problem we’ll have to deal with quickly.

I’ve taken action and pushed two changes to openHABian.

  1. I’ve improved the serial port function with a few nice features yesterday (not really related to the problem) https://github.com/openhab/openhabian/pull/102/files
  2. I’ve just now removed the suggestion to execute rpi-update and added the command to delete the program from your system with the menu entry “Basic Setup” (or on new installs). https://github.com/openhab/openhabian/commit/e14c8d1db54bc36ca262a5da4eb056d3552d3df1

This should stop others from running into problems till the issue is solved. Executing rpi-update should not be NEEDED, I’ve just recommended it till now because it’s a good practice. @syrenius your success shouldn’t depend on it.

I’ve opened an issue to investigate the actual problem, till then everyone should refrain from using rpi-update!

1 Like

Thx, I’ll try again without running rpi-update.

@ThomDietrich Just a question to prefend wasting time. Is it ok, when I do the following steps?

  1. Restore a backup-image, which I made after installing openhabianpi-ua-netinst-20170218-git11d8ebc.img.
  2. run sudo openhabian-config and execute option 1 (update), 2 (upgrade system), 10 (basic setup) and 30 (prepare serial port)
  3. reboot

Edit: plus option 10

1 Like

(just wanted to point to Basic Setup) Yes that should be it.

Restored the image

Got following message after restart sudo openhabian-config
/usr/local/bin/openhabian-config: line 445: syntax error near unexpected token `(' /usr/local/bin/openhabian-config: line 445: ` "#\nThis might be a good point in time to update your Raspberry Pi firmware (if this is a RPi) and reboot:\n'

-.- Sorry, that’s the price for a hotfix

@anfaenger It’s fixed. Please execute

git -C /opt/openhabian fetch origin
git -C /opt/openhabian reset --hard origin/master
git -C /opt/openhabian checkout master

Done and it’s okay now. After I prepared the Serial Port and rebooted, a login was possible!

Now I can go on with setting up my system.
That’s the advantage of getting hotfixes. :slight_smile:
Thx!

2 Likes

Can we provide an openhab2 folder inside of /opt/ with symlinks to the oh2-folders?
This would make it really easy to find all the files and would even allow easy sync to cloud services.

For example like this:

mkdir /opt/openhab2
cd /opt/openhab2

ln -s /usr/share/openhab2 openhab2
ln -s /etc/openhab2 conf
ln -s /var/lib/openhab2 userdata
ln -s /var/log/openhab2 logs

Sure, would be possible.
Could you describe the use case(s) shortly?