openHABian hassle-free openHAB Setup

raspberry
setup
openhabian
Tags: #<Tag:0x00007fd311397740> #<Tag:0x00007fd311397588> #<Tag:0x00007fd311396d68>

(SiHui) #1137

No, that has to be done through the “plain” linux bash.
BUT: see release notes of openHABian

With these additions raspi-config is now finally abandoned from the Raspberry Pi openHABian system.

Edit: see also


(Rolland J) #1138

Thank you.
But in openhabian-config has no option to enable camera pi module… :frowning:
No way to do that with openhabian ?
Doc doesn’t help me…


(Rolland J) #1139

Ok, it’s work !
You need to edit config.txt :

sudo nano /boot/config.txt

Change last line and add one :

gpu_mem=128
start_x=1

Check camera presence with :
vcgencmd get_camera

Solution found here :
https://www.raspberrypi.org/forums/viewtopic.php?f=43&t=63276&start=1500


( ) #1140

Hey @RollandJ, great you’ve got that working. Did you already find a way to include the camera module in openHAB? There are solutions for cameras out there, if you got a working setup for the RPi module, tell us about it :wink:


( ) #1141

Hey all, sorry for the late reply.

@ikjes_to The user root is not available by default. That’s not specific to openHABian but a recommendation and default for many Linux OSs nowadays. The command sudo reboot should work fine, the error suggests you did changes to your sudo config you shoudn’t have. Check google for a solution.

@peaeater did you slve your issue?


(Gerstl) #1142

I changed to an RPi 3 and I’am booting now directly from USB.

We will see if it will run now longer than a few month.

I was not able to restore a thing, because my SD-card is not booting any more.

I tried to understand what amanda backup is about, but I’am not getting the clue. It looks to complicated for me. And I’am sure that on restore time there will be missing to much.

I would like to create a continously (daily) image backup from my usb-stick to my nas drive out of the running system.

It is not enough to restore only a few file of openHAB, I also have to restore influxDB with all the data, grafana, and may be more. All the distinc user accounts/password have to be restored as well.

At the moment I have a running system again, with influx, with grafana and my fundamental bindings.

Still missing is the new modbus binding and digitalstrom binding.

All this is costing a lot of time and I will have to invest it again when my usb-stick crashes.

I tried to find out if I could rund an InfluxDB Server on my Synology DS216j, but there is no package available.
But I could install GIT to get at least all my configuration restored. But this also is not done in five minutes.

The ds216j is not capaz to run docker so this way is also not working.

So far I’am happy again.

But I have to find out urgently a working backup solution.


(SiHui) #1143

I’m running a 128GB SSD harddrive since one year without any issues.

If you don’t like Amanda, take a look at raspiBackup:

https://www.linux-tips-and-tricks.de/en/quickstart-rbk


(Gerstl) #1144

This looks good. But the problem I have with that is: How can I find out which services are running? How do I have to stop them and how do I restart them? If I make an mistake here the solution is not working for me.

But when I could solve this, this may be a working solution for me. Also the possiblity to compress the backup sounds good.


(SiHui) #1145

Actually you don’t have to stop any services if you don’t want to. This is the way I’m using it since almost 3 years now and back in the old days where I was using sd cards I had to restore a backup twice and it worked fine.
The only thing you would loose are some logs, but who cares.
A very nice feature are the the rsync backups with hardlinks.
If you want to be on the safe side, choose a backup strategy, make a backup and then restore it: you will see it works :grinning:


(SiHui) #1146

systemctl list-unit-files | grep enabled


(Gerstl) #1147

If this realy works I will give it a try in the next days.


(SiHui) #1148

I promise :sunglasses:


(Branden Smale) #1149

im sure this has been discussed, i just want to make sure first. using a rpi3, and a usb ssd…

  1. prepare the pi by configuring the boot mode

then

  1. write openhabian image, my case windisk32, to the ssd.

will this work, and keep from need for sd?


(Branden Smale) #1150

Also, I have bound the Karaf to all and am still not able to ssh into it via a browser. What do I need to check for?


(Markus Storm) #1151

You can’t ssh into anything via browser, you need to use a SSH client.


( ) #1152

Yes that should work, no I didn’t test it yet. If you can confirm this to be working, I’d happily add this possibility to the README.

To connect via SSH you need any SSH client software. See: https://www.raspberrypi.org/documentation/remote-access/ssh/windows.md


(Robert) #1153

Well, there are some ssh clients as Chrome extensions

https://chrome.google.com/webstore/detail/firessh/mcognlamjmofcihollilalojnckfiajm


( ) #1154

That is concerning :smiley:


(Marco Salinardi) #1155

Updated to version 1.3 and seeing this info

##   Release = Raspbian GNU/Linux 8 (jessie)
##    Kernel = Linux 4.9.35-v7+

I did something wrong that is not allined to stretch version or is only the information that is not updated?


( ) #1156

That looks okay to me. What’s the issue?