openHABian hassle-free openHAB Setup

ok, so it wont overwrite the config files, that was my concern

where can i find habpanel ui? its not where the github page says it should be. is it just openhabian?

i nelieve ive found my issue…experimental repo

Now I am having an issue after update today. Keeps saying jersey is not ready yet, reboot, all is fine for a little while, then jeraey is not ready yet again. any ideas?

Hey, sounds like a Habmin related problem?

should i not use habmin? what about my zwave devices, habmin has always been great

i cannot access anything on paperui, habmin, or habdroid. habdroid says jersey isnt ready yet, habmin says server is offline, and paperui just doesnt load any pages what so ever. should i re install openhabian and not install habmin?

but like i said before, habmin is so useful for zwave and most of my system is zwave based.

also, how do i access the karaf logs? i cant see any logs to see what could be going on.

http://docs.openhab.org/administration/console.html

and

http://docs.openhab.org/administration/logging.html#karaf-console

1 Like

No, you may use habmin of course. I’m just saying that this sounds like a Habmin related issue. openHABian installs openHAB but does not do any changes to it. All problems you have after setup are most probably unrelated to openHABian. Looking at the log is a very good idea. If you find a serious problem and it’s not already discussed here in the forum, it would be a good idea to open a new thread on it.

ok, thanks to both of you.

@ThomDietrich

how do i ssh into openhabian to view the karaf console. i tried to ssh in using port 8101, but im only allowed in using port 22.

While connected to your machine with ssh, type:

ssh openhab@localhost -p 8101

The default password is: habopen

1 Like

You need to first connect via ssh on port 22, then make another local connection as @Benjy said.

Another option: you can open the karaf console to all interfaces. To do that, please first connect via ssh (22), then type sudo openhabian-config, then select the option “Karaf Console”. After that you may connect from your local machine to your openhabianpi on port 8101

ok, that just seems easier, thanks

I get this error when trying to update openhabian:

What can I do?

And I want to update the zwave-binding to get the newest definition of chris’ database.

If I disable and reenable the zwave-binding - will it be reloaded from the net in the current version?

Michael

Looks fine to me :wink: There is no error.

To update openHAB and all it’s addons, just upgrade normally:

sudo apt update
sudo apt upgrade
1 Like

Thank you.

Now I have the new nice menu :slight_smile:
My KNX is running fine - what is knxd?
Do I need it?

Michael

Given that openHABian is mainly intended to be akin to an openHAB appliance, one wonders whether this shouldn’t be configured by default. Of course there are concerns with opening up a service like this, particularly one with a default user/password…

just for future questions…have to sudo ssh connection

Not sure what you mean but no, you’ll never ever have to execute ssh with sudo.
Can you tell me about the problem you are seeing?