OpenHabian install fails on Raspberry PI 4

  • Platform information:
    • New Raspberry Pi 4 8GB
    • OpenHabian image: openhabian-pi-raspios32-202308121256-gitc6a2fa1-crcc361b879.img.xz

I’ve flashed both the 32-bit and 64-bit images to separate MicroSD but both fail the same way, with neither WLAN nor ETH0 active after booting.

When using the hotspot approach, I specified the SSID and password.
I also tried modifying openhabian.conf before installation to specify the SSID and password but it still activated the hotspot.

The Raspberry Pi is in the same room as the WiFi access point and I’ve tried different SSIDs.

Connections via WiFi and ETH0 work fine with the base Raspbian image. I tried a manual install of OpenHab but couldn’t install OpenJDK 17.
sudo apt install openjdk-17-sdk
failed saying package not available.

I tried including part of the first-boot.log in this post but it was rejected saying new users can only include 2 links. (log has multiple URLs being tried)

I tried to upload first-boot.log but it says new users can upload attachments

isn´t it called openjdk-17-jdk instead of openjdk-17-sdk ?

1 Like

Please don’t try to setup openHABian via Wifi. Instead, hookup the Raspberry via Ethernet (and if it’s only for initial setup process).

You can include the log as text within the post (please mark it as code by using code tags)

your log goes here


Thank you.

I re-did the install using an Ethernet connection which worked fine.
But then how do I switch it to WiFi?

I ran openhab-config and set the SSDI and password.

After disconnecting and rebooting, the configuration message after logging in showed the Ethernet IP address and ifconfig didn’t show a WLAN connection.

Are there configuration files I can manually check and update? Also, some of the text is off the left and bottom of the screen.

If I can get Raspbian running with OpenJDK 17 would I be better off manually installing OpenHab?


Sorry, did not mention…
after completed setup, open the shell and start openhabian-config (with sudo)
Then go to 30 → 37 Wifi setup

Have a look into the scripts of openhabian-config ( wifi.bash ).
I think WiFi/HowToUse - Debian Wiki contains a collection of descriptions.

I did that to set the SSID / password, rebooted but no connection.

there should be messages / error messages during the start then in system log files.

When using openhabian-config, do you need to press the Execute button to have the change to the WiFi settings take affect?

Anyway, going through the WiFi setup again, picking a different SSID and rebooting, it worked! Maybe it was confused by the SSID I used previously that had both 2.4 and 5 GHz connections.

Thank you for your help.