openHABian Installation fails - Problem with user openhabian

  • Platform information:

  • Issue of the topic: Installation of openHABian ends with an error. I tried multiple times. What is the problem with the openhabian User? I hope someone can help me with that problem. Thanks.

  • Installation log:

2020-02-24_16:48:02_GMT [openHABian] Storing configuration... OK
2020-02-24_16:48:02_GMT [openHABian] Starting webserver with installation log...OK
2020-02-24_16:48:23_GMT [openHABian] Changing default username and password... SKIPPED
2020-02-24_16:48:26_GMT [openHABian] Setting up Ethernet connection... OK
2020-02-24_16:48:26_GMT [openHABian] Ensuring network connectivity... OK
2020-02-24_16:48:28_GMT [openHABian] Waiting for dpkg/apt to get ready... OK
2020-02-24_16:49:28_GMT [openHABian] Updating repositories and upgrading installed packages... OK
2020-02-24_17:10:21_GMT [openHABian] Installing git package... OK
2020-02-24_17:11:37_GMT [openHABian] Cloning myself... OK
2020-02-24_17:11:49_GMT [openHABian] Executing ' unattended'...
2020-02-24_17:11:49_GMT [openHABian] Checking for root privileges... OK
Hit:1 buster InRelease
Hit:2 buster InRelease
Reading package lists...
2020-02-24_17:12:00_GMT [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2020-02-24_17:12:02_GMT [openHABian] Setting timezone based on IP geolocation... FAILED
2020-02-24_17:14:39_GMT [openHABian] Setting locale based on openhabian.conf... OK
2020-02-24_17:16:12_GMT [openHABian] Setting hostname of the base system... OK
2020-02-24_17:16:14_GMT [openHABian] Installing basic can't-be-wrong packages (screen, vim, ...)... OK
2020-02-24_17:19:29_GMT [openHABian] Installing additional needed packages... OK
2020-02-24_17:20:43_GMT [openHABian] Adding slightly tuned bash config files to system... cp: cannot create regular file '/home/openhabian/.bash_profile': No such file or directory
chown: invalid user: ‘openhabian:openhabian’
2020-02-24_17:20:55_GMT [openHABian] Adding slightly tuned vim config file to system... OK
2020-02-24_17:20:55_GMT [openHABian] Downloading and setting up FireMotD... grep: /home/openhabian/.bash_profile: No such file or directory
/opt/openhabian/functions/packages.bash: line 35: /home/openhabian/.bash_profile: No such file or directory
2020-02-24_17:23:01_GMT [openHABian] Installing Java Zulu 32-Bit OpenJDK... OK
2020-02-24_17:25:48_GMT [openHABian] Installing or upgrading to latest openHAB release (stable)... OK
2020-02-24_17:28:00_GMT [openHABian] Adding an openHAB dashboard tile for 'openhabiandocs'... OK
2020-02-24_17:28:00_GMT [openHABian] Adding openHAB syntax to vim editor... chown: invalid user: ‘openhabian:openhabian’
2020-02-24_17:28:01_GMT [openHABian] Adding openHAB syntax to nano editor... OK
2020-02-24_17:28:02_GMT [openHABian] Adding openHAB scheme to multitail... OK
2020-02-24_17:28:02_GMT [openHABian] Preparing openHAB folder mounts under /srv/... OK
2020-02-24_17:28:03_GMT [openHABian] Applying file permissions recommendations... OK
2020-02-24_17:28:06_GMT [openHABian] Applying miscellaneous system settings... chown: invalid user: ‘openhabian:openhabian’
Creating persistent systemd journal folder location: /var/log/journal
Keeping at most 30 days of systemd journal entries
Deleted archived journal /run/log/journal/122b114983d941dab77ac21a9b900f92/system@5f483e09a3c74dbcbdd914a05f48aba5-0000000000000001-00058d48a7cef4c1.journal (2.6M).
Vacuuming done, freed 2.6M of archived journals from /run/log/journal/122b11498d941dab77ac21a9b900f92.
2020-02-24_17:28:06_GMT [openHABian] Setting up Samba network shares... Failed to add entry for user openhabian.
2020-02-24_17:32:37_GMT [openHABian] Installing Node.js for arm (prerequisite for other packages)... OK
2020-02-24_17:33:53_GMT [openHABian] Installing the openHAB Log Viewer (frontail) relative to nodejs base /usr/lib... OK
2020-02-24_17:35:20_GMT [openHABian] Adding an openHAB dashboard tile for 'frontail'... OK
2020-02-24_17:35:20_GMT [openHABian] Execution of ' unattended' completed.
2020-02-24_17:35:20_GMT [openHABian] Waiting for openHAB to become ready...1..2..3..4..5..6..7..8..9..10..11..12..13..14..15..16..17..18..19..20..failed.

Anything in the logs in /var/log/openhab2? Any hints in systemctl status openhab2?

openhab2 seems to run, but I can’t login as user openhabian


2020-02-24 17:39:02.594 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2020-02-24 17:39:19.172 [INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard
2020-02-24 17:39:19.511 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2020-02-24 17:39:19.513 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2020-02-24 17:39:19.520 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2020-02-24 17:54:57.986 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2020-02-24 17:54:58.421 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
2020-02-24 17:54:58.626 [INFO ] [openhab.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui

systemctl status openhab2

● openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2020-02-24 17:35:20 GMT; 2h 3min ago
 Main PID: 19101 (java)
    Tasks: 94 (limit: 1012)
   Memory: 194.7M
   CGroup: /system.slice/openhab2.service
           └─19101 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/openhab2/runtime -Dopenhab.userda

Feb 24 17:35:20 openhab systemd[1]: Started openHAB 2 - empowering the smart home.

Nothing showing at ?

I can access openhab at
But the log shows that the installation was not successful and I don’t want to use openhab with a failed installation. I can’t connect to my Raspberry Pi SSH console using the username openhabian and password openhabian as the user does not exist.

I have not used the direct image much so I am not sure at this point.

ok, thank you anyway

I got the same error today. I seem to have resolved it by adding the openhabian user.

sudo adduser openhabian

Might be worth a try.

Did you use the RPi image as the OP did ? Or did you install on an unsupported OS ?


I used a new RPI Buster lite image and cloned the openhabian.repo following this

It doesn’t say to do that there, does it ? It says on RPi to use the image so that’s what you should do.

1 Like

Not sure what you mean. I followed the Other Linux Systems (add openHABian just like any other software) section of the documentation.

Maybe I shouldn’t have done this.

The key word is OTHER. You are using a Pi that already had explicit instructions.

Ok, thanks