Openhabian no "/dev/serial/by-id" ==> no Zigbee2mqtt

After downloading a new Openhabian to SD-card (I want to migrate from OH3.4 to 4, made back-up and started with new SD to build up from scratch) I noticed some issues with installing Zigbee2MQTT. I’m running:

openHABian Configuration Tool — [openHAB3]{2023-08-16T21:49:21+02:00}(292689e)
openHAB 3.4.5 - Release Build

When selecting 20 - 2A (install or update Zigbee2MQTT) there are no zigbee USB devices shown.

Reading a little further this seems to be no problem from Openhabian, but from Bullseye as also discussed in this post I do have devices ‘by-path’ but not ‘by-id’.

ls -l /dev/serial/by-path
total 0
lrwxrwxrwx 1 root root 13 Sep 24 11:58 platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.1:1.0-port0 -> ../../ttyUSB1
lrwxrwxrwx 1 root root 13 Sep 24 11:58 platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.4:1.0-port0 -> ../../ttyUSB0

But not by-id:

ls -l /dev/serial/by-id
ls: cannot access '/dev/serial/by-id': No such file or directory

There’s a discussion in this topic below how to solve it. But if I follow this, I will divert from the stock Openhabian I love Openhabian because it takes care of a lot of the Linux stuff I don’t fully understand and. Is this being implementend in the Openhabian? Any advice what to d?

Did anyone succeed in installing zigbee2mqtt on RPI with openhanian / OH4?

Did you try the other workaround described in the thread you referred to here in the forum?

I just made a PR so that openhabian covers the bug of the missing /dev/serial/by-id.
The PR is
When the maintainer @mstormi merges it should work the next time you start openhabian-config.

1 Like

I tried but I think I did something wrong as it didn’t work. I’ll wait for the merge of the post above. Too afraid I’m going to mess things up.

it’s merged. please give it a try

I tried it; and it initially failed. Probably because I’ve been messing around too much.

I then flashed a new SD card with Openhabian and run some updates and now it seems to be working!

PS: to fully get it working I had to change the zigbee2mqtt configuration.yaml to:

  port: >-

openhabian was supposed to do that for you. What was written into configuration.yaml instead?

If I remember correctly it was by-id

oh, you’re right. There still a bug. I’ll correct that as soon as I got access to my test system.

bug should be fixed now with PR: