Openhabian - no internet connection on raspberry

(Jochen Bauer) #1

Dear Community,

I am running openHAB 2.4.0 (openhabian) and these days my internet connection isn’t there anymore. Anyone got the same situation? What are the next steps to solve this issue? See my logs attached.

2018-03-13_22:53:59_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_22:53:59_UTC [openHABian] Storing configuration… OK
2018-03-13_22:53:59_UTC [openHABian] Changing default username and password… OK
2018-03-13_22:53:59_UTC [openHABian] Setting up Ethernet connection… OK
2018-03-13_22:53:59_UTC [openHABian] Ensuring network connectivity… FAILED
2018-03-13_22:55:44_UTC [openHABian] The public internet is not reachable. Please check your network.
2018-03-13_22:55:44_UTC [openHABian] Initial setup exiting with an error!

Best regards,
Jochen

0 Likes

(Jochen Bauer) #2

Hm, strange … I pinged google.com and it works:

[21:48:47] openhabian@openHABianPi:~$ ping google.com
PING google.com(fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e)) 56 data bytes
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=1 ttl=57 time=24.0 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=2 ttl=57 time=22.7 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=3 ttl=57 time=22.8 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=4 ttl=57 time=23.0 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=5 ttl=57 time=22.9 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=6 ttl=57 time=22.9 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=7 ttl=57 time=23.0 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=8 ttl=57 time=23.1 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=9 ttl=57 time=23.0 ms
64 bytes from fra16s24-in-x0e.1e100.net (2a00:1450:4001:824::200e): icmp_seq=10 ttl=57 time=23.0 ms
^C
google.com ping statistics —
10 packets transmitted, 10 received, 0% packet loss, time 9010ms

So - where does this error message comes from, when logging into the raspi by using ssh?

0 Likes

(CM6.5 H102) #3

You can ping google so I would start with checking your DNS provider. Maybe even set the DNS provider to use google ( 8.8.8.8 or 8.8.4.4) for the initial OH setup.

Since your on an RPI please make sure the power supply is 5v 2.5A and in good working condition as a faulty power supply can lead to weird issues. The other thing to check is the Ethernet cable. For installing you might want to move the RPI near the router and move wherever after installing.

If that doesn’t work please provide as much info about your configuration as possible so we can troubleshoot further.

Hope this helps.

1 Like

(Tomasz) #4

I have the exact same issue as @Jochen_Bauer.
Yesterday I was able to install clean 2.4.0 on Raspberry Pi3.
I had no issues but after screwing the update to 2.5.0 M1 I formatted my SD and tried again.
I get this log:

login as: openhabian
openhabian@192.168.0.100’s password:
Linux openHABianPi 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Wed Mar 14 08:17:20 2018 from 192.168.0.101
Every 2.0s: cat /boot/first-boot.log openHABianPi: Wed Mar 14 08:33:11 2018

2018-03-13_22:53:39_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_22:53:39_UTC [openHABian] Storing configuration… OK
2018-03-13_22:53:39_UTC [openHABian] Changing default username and password… OK
2018-03-13_22:53:39_UTC [openHABian] Setting up Ethernet connection… OK
2018-03-13_22:53:39_UTC [openHABian] Ensuring network connectivity… FAILED
2018-03-14_00:18:47_UTC [openHABian] The public internet is not reachable. Please check your network.
2018-03-14_00:18:47_UTC [openHABian] Initial setup exiting with an error!

2018-03-14_08:17:11_UTC [openHABian] Starting the openHABian initial setup.
2018-03-14_08:17:11_UTC [openHABian] Storing configuration… OK
2018-03-14_08:17:11_UTC [openHABian] Changing default username and password… SKIPPED
2018-03-14_08:17:11_UTC [openHABian] Setting up Ethernet connection… OK
2018-03-14_08:17:11_UTC [openHABian] Ensuring network connectivity…

The weird part is that at first try it worked, not I’m formatting SD card again, switching ports in my router and nothing helped :frowning:

0 Likes

(CM6.5 H102) #5

From the command line can you ping google to verify that you have a connection that reaches the internet?

0 Likes

(Tomasz) #6

@H102 from my PC everything works fine. Other devices connected to my network have access to the internet (a couple of Wemos devices and NAS)
I don’t know how to check that from raspberry and openhabian.
When I SSH to my PI and login as openhabian I get first-boot.log content. I don’t know how to exit that to be able to execute commands,

EDIT:
I was able to exit log view with Ctrl+C :smile: (need to learn Linux commands bit more)
After trying to ping google.com I got this :

openhabian@openHABianPi:~$ ping google.com
ping: google.com: Temporary failure in name resolution

I’ve checked resolv.conf and it has this content:

Generated by resolvconf

nameserver 1.1.1.1
nameserver 1.0.0.1

when I call ifconfig I get this output:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.100 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::67e0:53a2:a4db:6c20 prefixlen 64 scopeid 0x20
ether b8:27:eb:05:cc:82 txqueuelen 1000 (Ethernet)
RX packets 3082 bytes 208648 (203.7 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1273 bytes 108867 (106.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether b8:27:eb:50:99:d7 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

as I mentioned all other devices in my home are working fine :disappointed:

0 Likes

(Tomasz) #7

For me the problem was a broken router. I just finished installing OpenWRT to my tp-link and just like that the problem is gone :smile:

0 Likes

(CM6.5 H102) #8

Glad you were able to get everything fixed.:+1:

As for the linux commands, search google for a list and bookmark it. Here’s a link that has a few commands that come in handy.
https://community.linuxmint.com/tutorial/view/244
The link’s for linux mint but most commands will work with any debian based system.

0 Likes

(Tomasz) #9

Thanks for the link :smile:

0 Likes