Openhabian not updating any config changes after reboot

  • Platform information:

    • Hardware:Raspberry Pi Zero W
    • OS: Latest Openhabian, Openhab 2
  • Issue of the topic: I am trying to change host, password, user etc. Everytime I change these settings and reboot it defaults back to openhabian:openhabian.
    It also appears to be reinstalling default configuration everytime I reboot.
    What do I do here? Do I have to remove a file to stop the constant default configuration taking place?

I have updated openhabian many different ways. Via config tool, via manual SSH. tried changing passwords in config tool and via SSH terminal. But when I reboot it defaults back to openhabian:openhabian.

I am lost. why is it reinstalling system config every reboot.

Using what methods?

Hi bruce, I have tried altering openhabian.config, ive tried changing settings in the openhabian-config tool and ive also tried changing password via terminal using passwd. It says password has changed but when I reboot it resets to default.

I am going to try a different path. Ill install an OS and install openhab inside it using the CLI rather than using the raspbian SD download.

@sp4c3mahn I have a feeling the openHAB install is failing. This is why you may get setting reset on reboot.

Prior to changing anything was the openHAB web GUI available? This would prove the install was successful.

You could install Raspbian Lite (using NOOBS), customize the OS using raspi-config, then install openHABian following the Linux install and have pretty much the same system. The image is just a cusomized version of Raspbian Lite.

Installing openHABian removes raspi-config due to some conflicts.

Im gonna try the raspbian lite as you suggested thanks Bruce if I have any more troubles ill update. But the openhabian was installing properly with web gui etc all working until I try to change config settings and reboot

1 Like

Don’t, instead debug your setup. Likely install has not finished. See if /opt/openHABian-install-failed exists. If you delete it, it should not restart install on next boot. But you should rather find out why your install didn’t finish. See /boot/first-boot.log what happened.
Then again you’re using a Pi0 which we do not support. It has not enough CPU & memory.


Ill check these logs tomorrow thanks for the info. I did have a quick browse I must of missed the supported devices part. I have a few Pi 4s in the mail so I can try those out too.

After playing around and the openhabian SD install was not working I did what @Bruce_Osborne suggested and installed Rasbpian Lite and then installed openhabian as per linux install.
All config files working and saving correctly.
Thanks for all the suggestions I am satisfied we can close this now. Now to play with my automated shed relays.

1 Like