Openhabian PuTTY SSH login

The other day I could log into my openhabian via PuTTY fine then today when I tried it, it just says “Unable to open connection to openhab Host does not exist” when I did the exact same thing as last time I logged on. I checked the hostname on my Raspberry Pi and it says openhab. Also on my Raspberry Pi it says “Then openHAB dashboard can be reached at http://openhab:8080” but when I go to that link it doesn’t work even though the other day it was working fine.


It’s probably your router. Hostnames can be unreliable.

What happens if you use the IP address?

I reinstalled openhabian and now I can SSH in using PuTTY however It doesn’t work when I try searching the IP address or openhab:8080

How long is the host up since reboot ? Is it 1 minute and 2 seconds or 1 hour and 2 minutes ?
In case it’s 1 minute then the webservice might not be up yet.
You can check that by e.g. running the command:

sudo netstat -tulpe --numeric-ports

This will list all listening ports. Check if port 8080 is in listening mode. Check if java is the executable that is running on that port.
What about the openhab.log file ? Any error message in it ?

I ran it again this morning and now its working

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.