Openhabian Samba username/password

After a successful, and seamless install experience, I was setting up Samba access. I found what I needed in the docs, (always read the docs) however feel like it needs a bit more clarity for beginners like me.

Samba (SMB) allows you to access a remote disk volume on your desktop, so you can easily navigate the file structure, and create and save files.

http://docs.openhab.org/installation/linux.html#mounting-locally

The default Samba credentials are openhabian:openhabian.

Even if you’ve changed the username and password for login to your openhabian setup ie ssh openhabian@X.X.X.X, the default samba credentials are still the default openhabian:openhabian.

The documentation is a little vague on this, and I hope this clarifies for some.

If you want to change your Samba password: sudo smbpasswd openhabian

Worked for me with this setup:
Hardware: Raspberry Pi Zero W, OS: openHABianPi Rev 1.1, openHAB version: 2.1.0-1

1 Like

Maybe this is new, but when I go to 30 System Settings -> Change Passwords the menu lets me select all the services including Samba and change them all to the same password in one go.

1 Like

For some reason, I can use r̶a̶s̶p̶i̶-̶c̶o̶n̶f̶i̶g̶ openhabian-config to change linux password, and it sticks. Samba, for whatever reason, does not :frowning:

EDIT: I also meant openhabian-config, not raspi-config

Sorry, not raspi-config, openhabian-config.

raspi-config should not be included with openhabian-config to begin with. I’ve created an issue for that https://github.com/openhab/openhabian/issues/289

@45Matches I take it the sentences you’ve posted in your first message are suggestions for additions to the article? If yes I’d be happy to show you how you can add them, I could also do that for you.

Even if you’ve changed the username and password for login to your openhabian setup ie ssh openhabian@X.X.X.X, the default samba credentials are still the default openhabian:openhabian.

Sounds logical to me :blush: Saying that A does NOT influence B feel counter-intuitive to me…

Did you find the “Change Passwords” option in openhabian-config to be the solution?

Hi Thom,

It would be pretty cool if you could show me?!

I would likely reword a little.

Changing the Linux login details, does not automatically change all login details. Even if you’ve changed the username and password for openhabian ie $ ssh openhabian@X.X.X.X, the Samba credentials will still be the default openhabian:openhabian.

As far as Change Passwords go, unfortunately, I’ve mixed results.On one install it worked first-time, and stayed working. On my current install, I’ve tried maybe 6 times, and the changes don’t stay stuck after reboot.

sudo openhabian-config
_ 30 System Settings
__ 34 Change Passwords
___ Samba
___ <OK>
___ ‘Set new password’

2 Likes

Hope this isn’t considered thread-hijacking!

Just did an install of the latest OpenHabian release today, and I cannot get into the Samba shares for the life of me. I am able to browse my pi, but the credentials are never accepted. Tried sudo smbpasswd openhabian as well, which hasn’t helped… The openhabian account appears to have the correct file/folder permissions, so I am a bit lost…

Weird, ran the tool from the openhabian-configlet and it works now! :smiley:

2 Likes

Hey Andrew,
to add content to the documentation you need to edit the article on GitHub. Please create an account there. After you can edit the article in an online editor by pressing the pen symbol on the top right:

The article is formatted in Markdown, in case you wonder about the formatting syntax. At the end of your edit you need to pay attention to the “sign-off” rule, see: https://github.com/openhab/openhab-docs/blob/gh-pages/CONTRIBUTING.md

Thanks for your contribution!

Regarding your suggested change. I really wouldn’t write it like this because “because A, B does NOT change” is logical. How about you go at it differently and mention something along the line of “The samba password is independent of the system password. In order to change it…”

@ThomDietrich

Been awhile since I’ve let you know what a great asset you are to this community…

Just installed the latest on a new sd card, new pi3…cannot connect to the pi with samba…keeps saying the folder is currently already mapped using different credentials…my old install was openhabian:openhabian; as should this one be. Windows won’t let me delete this network map. Any ideas?

Thanks

Branden

windows says current folder is already mapped with different credentials, but cannot delete, nor were the credentuals different before.

solved. had to change the host name…

I’ll add to this thread, as it seems I have a similar issue to many posting here.

I recently installed openhabian on a pi3 and cannot for the life of me access the samba share.

I’ve set the password via SSH and with the openhabian-config, none of these let me access the share. Is there an easy way to open the share up to guest access so that I can be sure that it isn’t a username/password issue? If not, can anyone suggest how I may be able to solve this?

Same problem here. I installed Openhabian (openhabianpi-raspbian-201712171718-git30faec3-crccc053823.img) on a RPI3 and cannot access the samba share from Windows 7 Pro 64.
Message is always invalid user/password combination. I tried to set the password to openhabian via openhabian-config, but still no success.

On a RPi ZeroW it worked just out of the box.

Hi Ren. I was able to solve this by changing the name of the pc that I was using to connect to openHABian. For some reason openHABian was convinced that I was always connected to the samba share, and until I did this it would not let me in.

Thanks for the hint, I changed the PC name and even tried another PC - no luck.
I solved the problem by giong back to Jessie - by doing a new install on RPi3 with Openhabian 1.3. Now Samba works out of the box.

That’s unfortunate. There are so many small things with OpenHAB that just don’t work as you would expect. It’s very detrimental to adoption I think.

Don‘t blame openHAB for Samba issues.
You could have Googled for Samba configuration and would have found the right config for allowing guest access.

O look a condescending response that also doesn’t help adoption.

FYI I spent a couple days combing the forums here and trying to enable guest access, even asking the question with minimal/no response.

To speak more directly, it’s likely an openhabian issue because of the way much of the files are setup and not standard.

1 Like

Did you try adding

guest ok = yes
public =yes

to your share config in smb.conf ?
This should enable guest acces, like you asked before