Openhabian stopped working correctly - either no paper ui or some items not initialized

I’m running openhabian 2.5.5-1 on rpi3 b+ and two weeks ago everything worked fine, until my rules stopped working completely, I rebooted the pi and everything except the the log viewer and help disappeared.
I did the following:

openhab-cli stop
openhab-cli clean-cache
openhab-cli start

after that I got the paper UI back but all my items were uninitialized.
after some reading I though it’s my SD card that started to fail, so I replaced it.
after I restored the system everything came back to life, but yesterday everything got broken again in the same way.
I can clear the cache and get paper ui back but than I have items not initialized.
here is the log from yesterday:
I’m not sure how to fix this, and I’m trying to avoid from doing everything from scratch.

For … reasons … you should restart openHAB a few times after clearing your cache. Some restart twice, I restart three times. Allow openHAB to start fully, then restart it, and then again if you want.

Doesn’t solve your initial issue though. Do you have enough resources (RAM, SD card space)?

1 Like

I think so, the most problematic as far as resources is RAM, but it seems to be just enough.
as far as rebooting, at the moment when I reboot the second time Paper ui disappears again.

I only mention it because I run on exactly the same hardware as you, and have had issues when trying to run too many things. Also, if connecting via SSH using Visual Studio Code to configure files and rules, quite a bit of RAM is used due to the remote server - which has tripped me up in the past!

Do you have any openhab or system logs from around the time that stuff disappears?

How long have these rules been running fine for? Have you added a new rule recently? Have you started using a new binding recently?

That’s not the right commands. You need to use systemctl [stop|start] openhab2 .

If you have a OH backup, I’d reinstall openHABian from scratch that gets you a fixed starting point.

Yes, thats my mistake in posting the problem, I actually did systemctl…

I have managed to fix the issue by cleaning cache, rebooting and them cleaning cache again and rebooting again.
You’re probably right about the RAM issue, I have added new items about a week before.
as far as the logs, They don’t show anything from when everything stopped working.
I think I’ll migrate the installation off the Rpi to a more powerful machine over the weekend.

1 Like

A RPi3 is absolutely sufficient, I use one myself. No point in moving for the sake of a performance increase.
Or let me put it like this: You will be experiencing the same problems on your other HW.

For openHAB, yes, absolutely. But we don’t know what else the OP is running on the Pi…

And you’re recommended to run OH on a dedicated system whatever the HW is.