openHABian testing

Okay, I’m a bit confused now. I wrote that based on the fact the it always happens around that time, and this night I now know it happened exactly at that time. I didn’t fully get this:

When you write “didn’t install fully”, I thought it may still have installed it partially? I don’t know which parts were installed and which were not.

What I’m referring to is only a relation to zram/zsync and the job/timer for that. I don’t know the details, so I’m not pointing towards anything more specific than that.

How to proceed? If you are 100% sure it’s not related to any of that, my logical next step will be to uninstall zram from openhabian-config and monitor the results from that.

If you believe there could be some kind of relation, I’d be happy to assist in reproducing.

This is also my feeling. Perhaps it only recovers when nothing is written to the logfile while the logdir is unmounted? Sometimes this will probably be the case. For me it seems to consistently fail, so maybe I’m logging more stuff continuously, increasing the risk of writing something just at the crucial moment.

I first tried to set log level for a binding from the console, which didn’t seem to help. When I did this from the UI, it helped.

Okay, I tried this, and it was reproduced on first attempt.

And does logging continue after an impulse ? (are you sure your loglevel console cmd was correct ?
I use log:set default org.openhab.binding.<somebinding> and it worked every time.

Yes to both. However, I might have been too impatient after the console command, I should probably have forced something to be logged.

I opened Logging stops when logfile goes away on zram sync · Issue #4227 · openhab/openhab-core · GitHub. Not sure if someone picks it up.
@wborn Wouter would you be willing to have a look ?

A post was split to a new topic: OS upgrade from bullseye