Openhabian upgrade to OH3 fails with server errors


I tried today to upgrade from OH 2.5.11 to OH 3. The Openhabian config fails, same with apt-get upgrade. Even upgrade to OH 2.5.12 failed. I get a server error “forbidden”. Browsing community pages didn’t reveal a solution. Was this a server problem ? Or is there a fix for it ?

Thanks in advance !

What version of openhabian-config do you use.
Acocrding to your message the old bintray repo is used in your setup.
Today there was an update for openhabian-config that switches to the correct bintray repo.


Ok, that server switch might explain it. I tried first with after a self-update of the config tool, after the first error, I played back the backup and tried without a self update first, both with the same result. Maybe my confit tool update hit the switch time ? About 18:00…

Hi, I can test again today, will try in the next days again (time permits)

Tried again, no success. What is the recommended way to change the bin repro ? An update of the config tool alone seems not to work ? How could I debug it ?

openhabian updates itself during startup.

In case you would like to do the update manually you need to edit a file in /etc/apt/sources.list.d.
You need to remove the old bintray entry and create one according to the documentation: openHAB on Linux | openHAB

yes, seems to work, it is updating now. I did:

>sudo rm /etc/apt/sources.list.d/openhab2.list
>sudo wget -qO - '' | sudo apt-key add -
>sudo echo 'deb stable main' | sudo tee /etc/apt/sources.list.d/openhab2.list

then tried the upgrade with openhabian-config. Not sure I need openhab2.list, as the frist command produces openhab.list anyway.

1 Like

I did this, but whenever I try to upgrade to Openhab3 with “sudo openhabian-config”, option 3, I still get:

2021-06-08_16:27:33_EDT [openHABian] Installing or upgrading to latest openHAB release (stable)... 
$ wget -O openhab-key.asc 
--2021-06-08 16:27:35--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2021-06-08 16:27:35 ERROR 404: Not Found.

Why is it still trying to upgrade from the defunct My openhab2.list no longer has any reference to this… WTF? Confused…

What openhabian-config version are you on ? The version is shown in the header of the window. The complete header line is required to identify the version.
I think you need to switch the branch. The stable branch is OH2.

Do a

grep bintray /etc/apt/sources.list.d/*

to check if there are other files containing bintray.

Grepping finds no other references to bintray… my version is:

openHABian Configuration Tool [master]v1.5-541(5158a5f)

Master branch has long been deprecated. That’s ancient which in turn is the source of your problem.
Didn’t you ever choose to let openHABian update itself on start when it asked you ?
If it didn’t ask you try cd /opt/openhabian; git checkout stable

And suddenly everything works magically! Yay! I had no idea that the alternate branching was even a thing (not really being a git guy), that I was on the wrong branch, or how that even would have happened… I only put together this instance of OpenHAB maybe a year ago… Super weird! But thanks! :smiley: