openHABian v1.4 / v1.4.1 released!

should i wait for the OH 2.2. release to update the openhabian, or should i do this now ? :slight_smile:
thanks!

I did a from-scratch install with the new image. I’m seeing a pretty core failure, right at the start. first-boot.sh runs for a couple seconds and dies. The OS itself seems fine, but there’s no logging to indicate what the issue might be:

2017-11-29_02:37:42_UTC [openHABian] Starting the openHABian initial setup.
2017-11-29_02:37:42_UTC [openHABian] Storing configuration... OK
2017-11-29_02:37:43_UTC [openHABian] Changing default username and password... OK
2017-11-29_02:37:48_UTC [openHABian] Setting up Wi-Fi connection... OK, rebooting...
2017-11-29_02:37:59_UTC [openHABian] Starting the openHABian initial setup.
2017-11-29_02:37:59_UTC [openHABian] Storing configuration... OK
2017-11-29_02:37:59_UTC [openHABian] Changing default username and password... SKIPPED
2017-11-29_02:37:59_UTC [openHABian] Setting up Wi-Fi connection... OK
2017-11-29_02:37:59_UTC [openHABian] Ensuring network connectivity... OK
2017-11-29_02:37:59_UTC [openHABian] Waiting for dpkg/apt to get ready... OK
2017-11-29_02:38:19_UTC [openHABian] Updating repositories and upgrading installed packages... FAILED
2017-12-18_20:09:43_UTC [openHABian] Initial setup exiting with an error!

Re-running it from the command line seems to work. Unfortunately without any diagnostics at all beyond that, I’m not sure how you’re going to fix it. It happened three times in a row, though, so its not a transient problem. If anyone else sees it, at least for me if you “sudo /bin/bash” and then run “/boot/first-boot.sh”, it’ll continue. (I found there’s something up with the shell script that fails if you do it directly “sudo /boot/first-boot.sh” kicks out with an error:

first-boot.sh: 4: first-boot.sh: Syntax error: redirection unexpected

1 Like

OH2.2 was release an hour and a half ago. My existing Openhabian install already prompted me to upgrade to it.

1 Like

Update!
I upgraded to OH2.2 and the karaf console is up and running.

Just an FYI, in openhab 2.2 you can access the openhab console anywhere on localhost by using the command:

openhab-cli console

when using an apt or yum installation.

Thanks, i upgraded to 2.2 and the most seems to be fine, but

my LOG stopped, its not refreshing ( xx.xx.xx.xx:9001 )
JSONPATH Items arent working
CSS styling is partly gone :smiley: - how do i activate the “Data Theme=Dark” ? :smiley:

i havent done any editing/fixing yet, so this is maybe fixed quickly - i’ll see :slight_smile:

thanks to the devs for their work :heart:

its a lot faster on my Raspb.3 in my opinion, the refresh of all the switches and buttons is now working as expected , it seems i dont need to do refresh my browser any more

THANKS AGAIN

EDIT:
this fixed my log:

Thx a lot for your very apprecitated work, ThomDietrich.

I just faced an issue with the additional dashboard tiles: The link behind the tiles do not respect my changes of the hostname.

Where do they get the url from?

Thx, G.

1 Like

Hello Peter, Hello @LuFriFri,
that is indeed true. I didn’t think about that (and it’s not straight forward). Let me file an issue, it will hopefully be fixed soon.
Till then you can change the used hostname inside /etc/openhab2/services/dashboard.cfg

Got a problem here. Wanted to update, so i executed “update” in openhabian-config and then this came up.


Any ideas?

EDIT:
Now i started the “UPGRADE” function under sudo openhabian-config. After that was successfully i wondered about that?!
2

OpenHAB 2.2.0-1 release build?
It seems that the update has been done?!

Hello @Boogieman,

something is weird with your openHABian configuration menu. It is not able to update itself out of a to me unknown reason. Good news: It appears you are on the latest openHAB version!!

To repair openHABian, please execute line by line:

sudo rm -rf /opt/openhabian
sudo git clone https://github.com/openhab/openhabian.git /opt/openhabian

sudo openhabian-config

That should be it. Select “Update” to verify it’s working.

Btw you should change your default password :wink:

1 Like

Hi,
made a fresh install of the new openHABian 1.4.

Now I want to install homegear via config-tool, but runs into error:

$ apt -y install homegear homegear-homematicbidcos homegear-homematicwired
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 homegear : Depends: libgnutls-deb0-28 (>= 3.3.0) but it is not installable
            Depends: libmysqlclient18 (>= 5.5.24+dfsg-1) but it is not installable
            Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
E: Unable to correct problems, you have held broken packages.
FAILED

Any ideas how to fix?

Thx for that. Now it works

Btw you should change your default password :wink:

Done :wink:

1 Like

Changing the system password (linux) didn’t work via openhabian-config, I had to use “passwd” instead. Am I missing a step?

I made a fresh install of the new openHABian 1.4 on sunday. I think openhab was still version 2.1 but I don’t realy know. After restoring/copying /etc/openhab2/ and /var/lib/openhab2/ all works fine.

But then I update openhab over openhab-config (think from 2.1 to 2.2) I get this error:

2017-12-19 20:12:29.013 [SEVERE] [org.apache.karaf.main.Main] - Could not launch framework
java.lang.RuntimeException: Could not resolve mvn:org.eclipse.tycho/org.eclipse.osgi/3.10.101.v20150820-1432
	at org.apache.karaf.main.util.SimpleMavenResolver.resolve(SimpleMavenResolver.java:59)
	at org.apache.karaf.main.Main.createClassLoader(Main.java:457)
	at org.apache.karaf.main.Main.launch(Main.java:254)
	at org.apache.karaf.main.Main.main(Main.java:179)


I decided to try this again…download openhabian 1.4, install (now it oh is 2.2) and restoring my files again and I get this error immediatly.

Any ideas?

Are you really referring to the system user ? I have that problem with the Samba password.
(and filed a PR to fix it for Samba).

2017-12-19_21:45:05_CET [openHABian] Changing password for samba (fileshare) account “openhabian”… Failed to add entry for user “openhabian”.
OK

Yes, the system password.
However I suspect the problem to sit in front of the screen. I was able to change that password in the previous edition, but I failed to get the one for the Karaf console changed. This time it was the system password, I didn’t even try the one for the console.
I’m starting the config tool with sudo, IMHO I can’t do anything wrong in the procedure to change a password.???

Is your system installed onto a RPi / Pine64 or have you used the tool on a generic ubuntu dist?

When you run the script for the first time it ask for the system user so it can handle all changes correctly.
If that one somehow is incorrect these function will not work.

I’m on a Raspi3.
Do I understand correctly, when using “openhabian-config” initially (without sudo) I’m getting the message that sudo is needed, input with sudo, confirming with password and then it should NOT work?

1 Like

Then you are doing everything correct.
This sounds strange to me, do you get any error in the console while running the password change function?

No error. The passwoRd just didn’t change. Tried it two times and then changed it via passwd.