openHABian v1.7.5 installation boot problem, WIFI - solved

HI i have been trying to install openHABian v1.7.5 all weekend on a rpi4b v1.1

it kept giving me errors on wpa_passphrase and exiting

Today finally i found the problem :slight_smile: long story short, there was a mismatch with the openhabian.conf and first-boot.bash

openhabian.conf defines the wifi password as “wifi_psk”
first-boot.bash is looking for “wifi_password”

After changing the openhabian.conf to match first-boot.bash i was able to complete my installation :slight_smile:

This is the image i used.

I made this topic to help others with the same problem.

EDIT: the error was caused by using parts from an older version openhabian.conf

Thanks Mads

1 Like

Are you sure the bad openhabian.conf entry wifi_psk originated from the openHABian image ?
At first peek that isn’t in the sources. Did you copy over some older .conf ?

Well i tried alot of things this weekend, ill flash another sdcard to see just to check the openhabian.conf

You are correct

And… i now remember that i took the password line from a old openhabian.conf early in the process :- :grimacing: :- :face_with_spiral_eyes: