Openhabian v3 installation fail

I am trying to install Openhab v3 with the hassle free Openhabian method on an RPI3 device. I also tried the default v4 installation and that worked without any issue, but v3 doesn’t work. I need v3 because of MySensors support. I set the following params in openhabian config file before installation:

  • clonebranch=openhab3
  • java=11

The installation finish and I can connect to Openhab with SSH, but admin portal http://host:8080 is not reachable. I am using fix IP for the device and that is accesible via SSH. Also by connecting by SSH I can see the following errors on welcome screen:

sed: can't read /var/lib/openhab/etc/ No such file or directory
sed: can't read /var/lib/openhab/etc/ No such file or directory

Do you have idea why that doesn’t work? I have multiple MySensores devices so I can’t move to v4. :frowning:

Thank you,

It is case sensitive and needs to be

Do you really thing that this can cause the issue? I don’t, because as I wrote I can connect to Openhab via SSH. The Openhab SSH welcome screen, with some errors, but comes up.

That just means the OS is there.

Still just about the OS, right ?

This is about the openHAB software package. The file that shows the version is not there.

This is about the openHAB software. Either it is not installed at all or an other problem but as the package version file is not there it looks like the software is not installed.

again this is just the OS part - as far as I understand you talk about the linux shell welcome screen.


There should be an easy check.
Login via ssh to the shell console ( not karaf ).
Check if any openHAB package is installed: dpkg -l | grep -i openhab
If any openHAB package version is installed it should be shown.

Besides that you may check the other forum threads there is a thread where an other user followed the documentation. One out of two documents showed openhab3 instead of openHAB3 and the installation had a problem, too.

It’s just like @Wolfgang_S says.
It’s a documentation issue and should do once you use the correct string.

1 Like

Yes you are right it solve it. I am sorry for I doubted. It should be updated in the documentation because I followed that.
I really appreciate your support, thank you.

could you post the link of the document with the wrong information here ?

here it is with small caps

Hi @Confectrician,
could you check / help here ? As far as I remember I have raised a PR to correct the typo from clonebranch=openhab3 to clonebranch=openHAB3 and as far as I remember it also has been approved. Opening github I see that is is corrected there ( at least when I use the link at the button of the related link to edit on github ). But looking to the page that is online it is still shown as clonebranch=openhab3

Even with the docs, not all changes get back ported to the anyway released docs. Do your changes appear in the “latest” docs?

If it’s there but not in the release version, your might need to make a new issue to get that back ported. I’m not sure what the process is for that but I know it’s manual.

openhabian docs are updated automatically and are always backported to our stable docs.
The changes should appear on the website soon.
I am a bit late, but have merged the pr for this change right now.