openHABian won't install frontail FAILED (adduser)

Tags: #<Tag:0x00007fbbbe6fe920>

Hi

I cannot install frontail using the openHABian UI. I think it is due to the fact that my user is not openhabian as I changed it in the openhabian.conf file before I booted my pi.

This is what I get when I try

$ useradd --groups openhabian,openhab -s /bin/bash -d /var/tmp frontail 
useradd: group 'openhabian' does not exist
FAILED (adduser)

A bug or something, I’ve done wrong? Thanks

[openHABian] openHABian configuration tool version: [stable]v1.6-880(769ea17)

Give more details upfront when asking for help. It’s annoying when we have to ask for each and everything, that’s not motivating to help you.

did you use the Raspi OS image to install ?

why do you want to install frontail, it should be installed already ?

when did you change the user, before or after installation ?

Upgrade to the openHABian master branch and use debugmode=maximum and try again.

Apologies, I was not being lazy I was just unsure what information you required upfront.

Yes

Sorry, maybe I’m not understanding correctly but on a previous custom install of openhab I used to be able to see the log in the browser but now I cannot. ip.address:9001 I could also just click it along with grafana, habpanel etc in the dashboard found at ip.address:8080

After I put the image on the sd card I opened the boot partition and edited the user and password in the openhabian.conf

I’ll update and debug maximum and try again thanks

So in the UI I went to: 20/21 Log Viewer. This is what I’m trying to get working.

[openHABian] openHABian configuration tool version: [master]v1.6-949(4310b40)

same issue by the looks of things:

$ useradd --groups openhabian,openhab -s /bin/bash -d /var/tmp frontail 
useradd: group 'openhabian' does not exist
FAILED (adduser)

:roll_eyes: Paste the full log

frontail should be installed by default if you run the image so you must not install again.

What does journalctl -xu frontail.service say?

Did you try the master branch (clonebranch=master during installation) ?
Never mind you would need a different image.
It’s (probably) fixed there. For the time being (stable branch) I think you cannot have both, frontail and a changed user.

I’m really sorry but I don’t know where to find the full logs. Where are they located? I’ve searched in docs but I’m really struggling. https://www.openhab.org/docs/installation/openhabian-DEBUG.html returns 404

journalctl -xu frontail.service
-- Logs begin at Thu 2020-11-19 14:56:11 GMT, end at Thu 2020-11-19 17:39:30 GMT. --
-- No entries --

I have not tried this no, would this mean starting the whole setup again? I assume it’s too late to change in /etc/openhabian.conf

Ha you beat me to it. So will it fix itself then in due course?

no, will only work if you install again.

where did you see that reference?

:sob: I may reinstall everything again then as little things like this bug me :wink: If I do I’ll let you know if it works.

https://www.openhab.org/docs/installation/openhabian.html#manual-setup in here all over the document.

not really it was 1 or 2 bad links only. fixed.

Great. There are 2 more that need updating at the bottom of the page.

So where is the log for future reference? I can see the first boot one is /boot/first-boot.log but what about after a successful install to DEBUG issues like I was having.

No it takes some time until the docs are updated from their sources.

Read up in the debug guide… there isn’t a log you need to record your terminal output.

Ahh ok, makes sense, many thanks for your help :+1:

I started again:

  1. added master in openhabmin.conf
  2. ran “upgrade all installed packages”
  3. restored my previous openhab backup
  4. tried adding log viewer again

same error (better log for you now :wink:)

my.log (9.6 KB)

you can edit /opt/openhabian/functions/nodejs-apps.bash line 69 and replace “openhabian” by “${username}”

1 Like

Updating the file worked. Just updated to the latest master and can see you fixed the issue. Thanks again!