Openhabianpi first-boot failure

I have the OpenHABianPI image burned in an SD card and I start a RPi 2
The installation fails with the message:
2018-03-13_23:26:19_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_23:26:19_UTC [openHABian] Storing configuration… OK
2018-03-13_23:26:19_UTC [openHABian] Changing default username and password… SKIPPED
2018-03-13_23:26:19_UTC [openHABian] Setting up Ethernet connection… OK
2018-03-13_23:26:19_UTC [openHABian] Ensuring network connectivity… OK
2018-03-13_23:26:29_UTC [openHABian] Waiting for dpkg/apt to get ready… OK
2018-03-13_23:26:42_UTC [openHABian] Updating repositories and upgrading installed packages… OK
2018-03-13_23:37:19_UTC [openHABian] Installing git package… OK
2018-03-13_23:37:51_UTC [openHABian] Cloning myself… FAILED
2018-03-13_23:38:03_UTC [openHABian] Initial setup exiting with an error!

I am behind a proxy server and the first time I started the RPi it failed, then I got into it with SSH and added the proxies for
I alse remove the ssl check from git with
git config --global http.sslVerify false
But I don’t know what to do now.
A question that I have also (which might solve this error) is:
Is there a way to setup proxy server on the sd card before running it for the first time?

So as I am reading in this thread:

/usr/bin/git clone -b master /opt/openhabian &>/dev/null

the git clone command is failing but when I tried that with ssh, the clone part worked ok
that whole command (with sudo) works perfectly

This is the error I get from git

fatal: unable to access '': server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

But I have configured it to NOT use ssl.

git config --global http.sslVerify false

But you are using https which requires ssl. Try using http.

It seems odd that the github server would have an invalid certificate.