Overhaul and rebmission of WiZ Lighting binding

I had just tried 3.1.0M4 as well , and none of my added in bindings (this one and Plex) worked. I switched back and they work again. (sorta… having issues with the Plex binding)

  1. how is your network settings in OH configured?
  2. how is your container started?
  3. Is your container bound to the HOST network or custom bridge network?

My container is on a custom bridge network, but I had it bound to the HOST network when I was adding the bulbs, then switched back to custom bridge and they work fine now.

One thing I am trying (as I type) is forcing OH to bind to the HOST IP with an update to runtime.cfg (which looks like it’s working)

Hi Frejos,

Any chances you could submit your binding to the official distribution? Been using it a lot and it is very solid. While I realize there might be some edge cases, it would be really nice to have it supported as part of the main distribution.

Btw - I just bought a new Wiz A21 - and unfortunately, that one is not recognized by the wizard. Let me know if you need any details. A21 works perfectly after a OH restart.


1 Like

I figured out my .thing file…… needs spaces on both sides of the [ ]s… just to be clear, inside and out… I’ll have to edit this (or post a follow up) for my thing example.(when I’m not on my phone)

On that I confirm everything works as intended on 3.0.2…. I’m looking at Zwave issue in 3.1.0 (potentially related) But that’s one of the benefits of running in Docker, it’s so easy to change versions (or have multiple running, though I can only attach the Zwave adapter to one at a time).

Confirmed working in OH 3.1.0 release using the jar file from github in the add-ons folder. The lights were immediately picked up and in my inbox. They have numerous useful channels and work decent for a $13 RGB bulb.

Issues I’ve encountered, none annoying enough to make me return them. They serve their purpose even with these little bugs. Most of what I do with these lights is executed through scripts and rules for hard coded scenes. So all of these issues below really have no impact. But if you’re planning to use widgets to control specifics of the lights, it will be a little wacky.

  • Dimmer channel does not dim to zero (off). Minimum seems to be 10%. Selecting zero just bounces back to 10.
  • Color Temp channel controls the white color temp. But this doesn’t stick when other color settings are changed. Whatever you had it set for reverts back to ugly 2000k-ish. Using the slider for the color temp channel is unreliable. The dimmer channel and on/off channel do not mess it up.
  • Brightness in the color channel takes the saturation setting and dimmer channel with it, which is odd and messes things up for later.

Thank you so much for this binding! I have 8 of the 60w bulbs 2 of the 100w bulbs 1 candelabra bulb and 2 high hat bulbs all RGBW that work great!

2nd on the dimmer channel. I wish i could turn the bulb off when i dim to zero but its not a huge deal. I actually started replacing my outdoor lamps with these and moving the zwave switches that were on those lamps to other items.

Even an Off mode in the light mode list would be helpful.

Thank you again for your time and efforts!

For 11 bucks a bulb its cheaper than the 30 dollar zwave switches.

Well I just tried to go to 3.2 milestone. Everything exploded and seemed to be related to this binding. Had to roll back to 3.1 stable

no issues here with the wiz binding on 3.2. You might need to clear the cache through. (openhab-cli clean-cache)

I’m thinking this binding should be submitted to the official release. It has more features and is more stables than other bindings bundled in the official release.

When you went from 3.1 to 3.2, did you use Openhabian to upgrade, and leave the binding in the add-ons folder untouched? It just worked? Clearing cache before or after upgrade?

edit-- Immediately after switching to 3.2M4 in OpenHabian, I stopped the service, cleared cache, and rebooted. Everything including Wiz bulbs came up flawlessly. Thanks.

Yes pretty much… I did the upgrade with Openhabian, then it used apt update/upgrade to update Openhab. If I recall correctly, the first startup did not work well and I had to re-install 3.2 twice and cleared the cache after starting it once. But after all of that, it just works fine.

Thanks for the binding! Works for me in OH 3.1 with A60 (E27 bulb).

Initially I hoped to tasmotize the bulb, but the damn thing has no srews on pcb, glue only. Disassemble without destruction seemed impossible.

Anybody else getting this error when trying to set the Speed on a Dimmable bulb?
2021-12-14 23:15:20.545 [WARN ] [ternal.utils.WizResponseDeserializer] - Bulb returned an error on method “setPilot”: -32602, Invalid params

Dimmer _frFPLightBSpeed “Family Room FP Light B Speed” {channel=“wizlighting:wizTunableBulb:xxxxxxxx:speed”}

OpenHab 3.2.0.M3

Maybe a beginners question; but my implementation did not work.
I am using openhabian, and pulled it on /etc/openhab/addons
It has pulled the repo correctly in a directory /etc/openhab/addons/openhab2-addons, but I cannot find new things in my inbox, neither a new set of bindings…
what did i do wrong?

Hey everyone,

I have worked to get things a bit more streamlined. I had to untangle the code branching and forking a bit and update things for some of the new versions of OH builds. Nothing substantial has changed from the previous version though, however it is now published and available as a community marketplace binding and has been rebuilt using 3.3.0 base code but may work in other 3.x.x base installs as well.

Installing from Marketplace

  • Go to Settings, Add-ons, Bindings…
  • Under Community Marketplace, find ‘WizLighting Binding’
  • Install it

Upgrading from Manually Installed to Marketplace

In order to update to the market place version, you will need to:

  • shutdown OH
  • remove the JAR you manually placed in the addon folder
  • use the openhab-cli clean-cache command to remove any cached versions of that JAR file
  • restart OH
  • Go to Settings, Add-ons, Bindings…
  • Under Community Marketplace, find ‘WizLighting Binding’
  • Install it

Manually Upgrade or Install

In order to update to the latest version, you will need to:

  • shutdown OH
  • remove the JAR you manually placed in the addon folder (if upgrading)
  • use the openhab-cli clean-cache command to remove any cached versions of that JAR file (if upgrading)
  • place the org.openhab.binding.wizlighting- file in the addon folder
  • restart OH

Marketplace Thread
Updated Source Code Repository

1 Like

Hi, I am not yet an OH user but deinitely plan to be one soon.
This solution looks as a very nice example of community support if I understand it right. Great job!
However, I wonder, how come the Wiz lighting support is something not listed in OH official binding list?
Isn’t Wiz lighting very popular and OH ‘binding almost all protocols’?

Just wondering? :slight_smile:

Well, everything in openHAB is community work. And volunteer work. So you may think of it like that. If it’s popular, usually someone interested will pick it up :slight_smile: if it’s not, it’s less likely…
Since there’s not an oficial binding yet, I assume that it’s not that popular :stuck_out_tongue:

It is new, and it seems with its SpaceSense (motion detection using existing wifi, no need for motion sensors!) should grow fast …

But, this binding mentioned here works well, I assume, right?

The WizLighting binding was created several years ago and was submitted for inclusion in the standard distribution, however, the pull request process was time consuming and the criteria was very strict and after many attempts and much time the original developers gave up attempts to get it included.

Others including myself who use the binding have continued to keep it viable and make enhancements over time. In recent versions of OH, a community marketplace was added that created a means for the community to deploy and install these bindings in an easy way. So while it isn’t an official binding, it is installable directly from the community marketplace (now) and it is a very stable binding.

As stated it really ultimately boils down to the commitment of time, availability of someone who needs it and also has the skills to maintain it… for me I have an install of around 40 Wiz devices in various configurations and uses on my network. So I have a vested interest in making sure that this binding keeps working.


@Pedals2Paddles @palazzja Noticed your comments about dimming to zero and tracked down the bug that prevented that. Dimming still must be >= 10% but now dimming to 0 will correctly turn off.

This is fixed in version Updated in marketplace thread.

Legend!!! Thank you so much. I went a little overboard and ended up with like 25 Wiz bulbs on my OH setup. Cant wait to try out the new 150w 2500 lumen RGBW monstrosity.