Package 'zulu-8' has no installation candidate

I try to install Openhab2 according to on Rpi but cannot get Java to be installed.

pi@raspberrypi:~ $ sudo apt-get install zulu-8
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package zulu-8 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘zulu-8’ has no installation candidate

Because I’m really a newbe on Raspberry and Linux I need to get help.

Tanks in advance.

And it recommends using openHABian. That is not what you did. Just follow the “Other Linux Systems” instructions.

Bruce thank you for your fast update. I followed your suggestion, but I cannot start openhab on Port 8080.

sudo systemctl status openhab2.service
openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; 
vendor preset: ena
Active: active (running) since Mon 2019-11-25 23:05:34 CET; 32min ago
Main PID: 531 (java)
Tasks: 49 (limit: 2200)
Memory: 218.1M
CGroup: /system.slice/openhab2.service
       └─531 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 - openhab.conf=/etc/ope

Nov 25 23:05:34 openHABian systemd[1]: Started openHAB 2 - empowering the smart home.

I can see the port is open but get the follwing problem:

HTTP ERROR 404 Problem accessing /start/index. Reason: Not Found 
[Powered by Jetty:// 9.4.11.v20180605](

So I need another hint.

Wait. It is still starting up. :wink:

I waited the whole night, did a reboot - but my problem isn’t solved.
What could be the reason ?

What do the openhab logs indicate? It is possible restarting openhab could help.

Openhab restarted
Browser cache cleared
Logs: /var/log/openhab2/ audit.log, events.log, openhab.log are all empty.

Still the same:
HTTP ERROR 404 Problem accessing /start/index. Reason: Not Found

Have you used the openhabian-config tool?

What is the output of java --version?

I did a new installation on an empty SD-Card
First I installed an Image with piVCUU.
Attached 2 sensors - OK
Next I followed

When I came to the “Manual/Fresh Setup” recommendation I did all steps including Java 32 and 64 Bit.

And now it works. At Port 8080 I get the openHAB2 Initial Setup screen.

Maybe that in my first approach I didn’t do all the steps recommended in “Manual/Fresh Setup”

Thanks for all who gave support to me.

1 Like

This solution only works for RPi using openHABian.
I experience the same problem as in the initial comment “Package ‘zulu-8’ has no installation candidate”.

When I follow the official installation instructions on, I still get this error afterwards. I assume that their apt repository link is broken. The command is sudo “apt-add-repository ‘deb stable main’”, but browsing that repo gives an error.

Could someone please provide me the apt repo which is used in openHABian (apparently it is working there)?

Use Google search. It is listed in the GitHub repository.

These are only docker installations, or am I missing something?

OpenHABian does not use Docker.

1 Like

Sorry, I don’t find the apt repo in there. There is a tar.gz file, but I can download that from the zulu homepage as well and I don’t know how to make a full install from that (just unzipping the archive doesn’t get me anywhere).
Sorry, I need more details…

Not every software product maintains a repo for every type of Linux distribution. Apt is specific only to Debian and its derivatives.

What is the output of update-alternatives --config java?

no alternatives for java.

I uninstalled Oracle Java prior to installing Zulu.

I’m a Linux beginner only, so maybe I can get the tar.gz running, but I need help with that please.

What I can do is:

cd /usr/lib/jvm
tar -xzvf zulu8.42.0.195-ca-jdk1.8.0_232-linux_aarch32hf.tar.gz
mv zulu8.42.0.195-ca-jdk1.8.0_232-linux_aarch32hf zulu-8 # not sure if needed or any good
export JAVA_HOME=/usr/lib/jvm/zulu-8/
export PATH=<old PATH, Oracle java stuff removed, /usr/lib/jvm/zulu-8/bin added>

But this still does not configure a java alternative, and I feel I might be missing some steps?

I’ve been using Linux for years and still feel like a noob at times.:smile: It doesn’t help that I also use different Linux OS’s and get things crossed up.:roll_eyes: Don’t give up and use google search to help with where the correct path should be for whatever your downloading/installing.

I’m useing openhabian so give me a few minuets to verify the apt repo that I have.

Here is what’s showing on my system:

Screenshot at 2019-11-29 10-41-07

@yannick_hein what OS are you using, looking at a few post above seems like your on Ubuntu? If so, you may want to start a new topic as this one has been marked solved. In the new topic please add your OS and version of OH to be installed. I’m sure someone in the forum that is more familiar with Ubuntu can help.

Here is also a link that you may find helpful. Initial setup failed on RasPi3B+ due to a Java - Zulu path error