Page "Home" - How to access?


i set up the sematic model now and i want to display my home (mainly on my iPhone and iPad).
If i access with my computer i can find it under configuration but i am missing something. Do i have to “release” it somehow?
In the url there is still settings/home/home

Or is this page not for use at all and i have to manually configure a page? i hope not so :slight_smile:

Thanks for your help!

Your configurations shows that the model cards are only displayed to Users and Administrators.
So therefor you have to login.
You can also unselect the restriction so the model cards will be shown to anyone who has access to:

When you open the URL for your openHAB (e.g. it will open the overview page by default. The overview page consists of four tabs. The first is a Layout Page you need to create and configure and the remaining three are autogenerated based on the semantic model.

Notice the URL.

Note, if you click on the openHAB logo in the upper left corner, that will take you to the Overview page too.

I don’t think that’s the problem because the lower left shows that they are logged in which means they would be able to see it. But to make sure, you can go to Settings → API Security and make sure that “Implicit User Role” is toggled on. That will give the “Users” role to anyone who brings up the page even if they are not logged in.

1 Like

Thank you for your replies!
I did not create the overview yet.
Is that the reason the app does not show anything? I dont know what to write in the field default path. Or is there another issue? Pw is set correctly.

I think you are not logged in.
Please log in using the menue button on the top right.
Then you will see the model cards.

You don’t create the Overview page. It’s there by default. The first tab may be blank if you’ve not configured the layout tab yet but the other tabs will be populated from the semantic model.

Before you were talking about in the browser. If you are not talking about an app, which app? Android or iOS? I don’t think MainUI is supported in the iOS app yet (I could be wrong, I don’t follow the iOS app’s development). If the Android app you need to click on the hamburger menu (upper left corner) and select “openHAB 3 UI” to see MainUI.

Beyond that, assuming Settings → API Security → Implicit User Role is toggled on, there is nothing you need to do to create or see the Overview page. It’s there by default. It’s always there. You don’t create it.

Yes, it is working.
It works via browser even if i am not logged in. I checked that.
Thank you. I was not aware of it maybe not being implemented in ios yet. I will check that.
I did this mainly because i have huge problems with the sitemaps in the app so i thought this would be the new way.

You can use the iOS Testflight App for OpenHab. here
This one supoorts the MainUI for sure.

It worked exactly once.
Then i tried it with WiFi turned off and got an error and now even local access is not possible anymore.

But the browser works fine. Thank you.

I guess i’ll put more effort into establishing an “always on” - vpn tunnel to my unifi setup.

The testflight app is working perfectly. Make sure your connection settings for remote and local access are correct.

I dont blame the app.
Something is wrong with my setup and indont know what it is.
The credentials are correct but i dont get access. I get push notifications but cant see my pages or sitemaps.
Anyhow. I set up a permanent vpn on my iphone now and can live with that.