Pairing Multi openhab instances with homekit

I have 2 differents locations where I have installed 2 servers with 2 OH3 (totally independent)
The first location (house) is well configured and paired with homekit.
Now, since a couple of days, I am trying to pair the second house (created a new home in homekit) and tried to pair the second instance of OH3 with this new home, but unfortunately, I didn’t succeed, it always says “Accessory Already Added”
I’ve tried to play with the pin code, but I was not sure what to use as pin code and if it’s really due to that ?


As far as I understand this message is an error message in the homekit app.
To me it sounds because the app/homekit is not able to distinguish between both openhab instances.
Looking into the OH homekit integration docs the configuration at the OH end has capability to configure the instance name


Document says:>

Name under which this HomeKit bridge is announced on the network. This is also the name displayed on the iOS device when searching for available bridges.

I would try to change this one on the instance that you cannot pair yet.

With regard to the pin which also can be configured the doc explains

Pin code used for pairing with iOS devices. Apparently, pin codes are provided by Apple and represent specific device types, so they cannot be chosen freely. The pin code 031-45-154 is used in sample applications and known to work.

Thanks Wolfgang_S
I tried to change the name but same issue. didn’t succeed to add the second OH3 instance (same error message)
same for the pin code, changed it and used the “123-45-678”
but same issue

based on the documentation

At the very least, you cannot use repeating (111-11-111) or sequential (123-45-678) pin codes.

I would assume that it may not work.

I then would set the debugging level of the homekit integration addon to trace level. May be it gives information about the exchange settings.

Thanks Wolfgang_S, I really appreciate your help.
I think I figured it out.
The problem is coming from the fact that I used a backup of the other instance to duplicate some things and item (to save time)
and I am sure the problem was coming from there (I have copied a file that I should have not) maybe containing the UUID of the instance …
I can’t say which file exactly.
but I can say when I purged/removed OH3 and re-installed it. now it works perfectly.
Multi openhab instance configured with one homekit account.

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.