Paper UI very, very slow


i searched the forum for a solution, but only find similar problems without a solution.

I have a fresh setup of OH2 (version 2.3.0). Installed the following bindings:

  • Network Binding
  • Sonos
  • Homeatic Binding

I also installed homegear to set up 1(!) intertechno plug and samba for windows shares.
After a restart the homegear link to my plug does not work anymore and the paper ui is very slow. Control, Things and theire conifguration load very, very slow. It is almost impossible to use the web ui.

Least thing to explain if you want others to help is your HW/OS/Java setup.

Oh, of course:


  • Raspberry Pi 2 with 16GB sdcard
  • CUL USB stick 868


  • Raspbian GNU/Linux 9 (stretch)
  • openHAB 2.3.0 Release Build
  • Homegear (version 0.7.30-1900)
  • Java Version “1.8.0_191” / Java™ SE Runtime Environment (build 1.8.0_191-b12) / Java HotSpot™ Client VM (build 25.191-b12, mixed mode)
  • Samba Version 4.5.12-Debian

First of all i installed Java 8, then OpenHab2 and then Homegear.

I hope, these information will help. Otherwise i can provide more information.

Thank you for your help in advance.

Switching between system, bindings, services etc. in paper ui is no problem. But if i load “my” things e.g. control or things, it will slow down and the loading is very slow.
If i click on things in the paper , i see in raspbian "top"openhab/java at first place with CPU usage 100%.

UIs are laggy while OH is busy recompiling items config and rules file (which your 100% Java CPU is a sign of).
Are you editing openHAB config files in-place ? Maybe even over Samba ? Maybe even use VS code extensions ? Change to off-place edit+copy. There’s a couple of posts here on the forum to elaborate on that.

I edit the files via Visual Code and Samba share. I found this problem description in the forum and so i closed every connection. I closed visual code, notepad++ and every folder via samba to raspbian.
I restartet the pi and my computer as well. Everything startet normally and i start the browser to configure via pap ui. At this moment it is very slow. Therefore i started a new thread here, because there is no recovery.
Even if i use copy the file via samba to off-place, edit it and copy it back - no changes!

Note if you make n changes that’ll result in n consecutive compile runs, this can leave the impression it’s a neverending loop.
And if it isn’t you to edit these there pretty likely still something is around to change your files. Enabled debugging on org.apache.karaf to get noticed of compile runs.

I have the same problem. My openhab runs stable on a pi3b, load average around 0.4.
No editing of files, no VSCode connected (VScode really kills my openhab in no time).

When I open paper UI, it is responsive until I go to any page that involves items.
The item list itself takes about one minute to load. If I go to a thing and list the linked items, it’s the same.

Any hints on how do debug this?

Okay I don’t know whom this might help, but I had the same issues and I resolved it! I’m using OH4 on a Raspberry Pi, and I enabled the NGINX reverse proxy. I didn’t edit any files of the nginx config, and somehow PaperUI was still accessible without SSL from the local network. Using this way to access PaperUI was the problem! When I used my remote access domain from a local computer, there were no delays! So I configured NGINX to allow access from local LAN (which it did before, but with those looong delays), and everything worked fine!

Welcome to the community.
I am sorry, but your post does not help anybody, cause the original issue was with openHAB 2 and PaperUI. You are using openHAB 4 and the new MainUI. This is completely different.