PaperUI "Control" empty (Snapshot #925)

That’s correct for the /etc/apt/sources.list.d/openhab2.list file for apt-get commands (update/upgrade)

What about the entry for the online repo for addons on /var/lib/openhab2/etc/ (should be:

Something else is wrong then and it’s not being created…

I am lost :frowning: I don’t know what to suggest :stuck_out_tongue:
Maybe post some of the contents of the fileinstall-[...] and/or hs_err_pid[...] files?

what about flushing tmp folder ?

fileinstall folders are all empty

To eliminate this possibility: Check permissions, available disk space, and similar stuff that would prevent openHAB2 to create the /var/lib/openhab2/tmp/mvn directory and subsequent subdirs within that…

permissions are ok openhab:openhab
diskspace also.

i have just cleared tmp folder
and this is the result after oh2 start

/var/lib/openhab2/tmp# ls
fileinstall-8738955009357315628  libNRJavaSerial_openhab_0  lock  port

btw this is

openHAB Distribution Version Information
build-no        : Build #925
online-repo     :

Repository        Version
openhab-distro  : 2.1.0-SNAPSHOT
smarthome       : 0.9.0-SNAPSHOT
openhab-core    : 2.1.0-SNAPSHOT
openhab1-addons : 1.10.0-SNAPSHOT
openhab2-addons : 2.1.0-SNAPSHOT
karaf           : 4.0.8
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007fb530f41274, pid=1271, tid=0x00007fb537064700
# JRE version: Java(TM) SE Runtime Environment (8.0_131-b11) (build 1.8.0_131-b11)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.131-b11 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  []  JBusAttachment::Disconnect()+0x4d4
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

and also

is existing from the update yesterday timestamp

there is this in latest hs_err_pid log

I am out of ideas… I think that we need a more expert troubleshooter to help us here :slight_smile:

I tried to google the C [] JBusAttachment::Disconnect()+0x4d41 but I couldn’t find anything useful…

Which bindings are you using? Maybe try to uninstall them to see if this helps…

Also: can you get into the console or OH2 doesn’t get that far?

yes karaf console etc. is working, i just realized that “Control” in paper ui is empty.

i see just right now, there must be something else wrong.
also the log files in /var/lib/openhab2/logs
latest written on 22.05.2017 20:58:56
no newer entries.

all the automatic is working fine :slight_smile: rules sitemaps, also habpanel
log:tail in console has output

interesting… so OH2 is (partially) working but it seems that it is not writing stuff to the file-system ? (example: logs and temp)?

I would invite Kim here to do a complete re-install of the OH2 Snapshot (backup configs, apt-get purge and then install) :slight_smile:

just did it :slight_smile:


apt-get purge openhab2*
install latest snapshot

restored the files
same issue :slight_smile:

there must be something within these restored folders

just also purged oracle-java8-installer and installed again, same issue

Can you skip the /var/lib/openhab2/ dir from your restore? (Put back only only /etc/openhab2/)
You will lose jsondb, habpanel and other configs like this.

i just reinstalled again with purging before
restored nothing.
and added 3 allplay speakers
“control” panel is empty like before
tried on diff. browsers and pcs + mac.
but mvn folder with its content is build now

Then it seems to be some issue with the binding.

The same error that you got is discussed in the thread above

I’ve seen this happen if I have Things that are in “Uninitialized” state (like when the binding for those Things is stopped). When I deleted those things, everything in the Control panel showed up again. YMMV

so i have restored files again, removed all bindings, just yahoo weather, network, z-wave binding is installed. and removed related things
but no control panel

the control panel was working before some days, not sure when exact i opened last time.
i have added some things in past days, so maybe there is one thing which cousing the issue.

but still dont find a way to debug the panel while opening control panel

@mhilbush there is no uninitialized thing

Oh well, it was worth a shot.

I’m also on Ubuntu and just updated; no issues whatsoever.
Maybe you have added an item which has an “%d” in it’s label?
This created the same issue for me a while ago.Replacing all “%d” with “%s” solved this issue for me.
There are some threads about this issue as well…

I had also a broken Control Panel after upgrade. But the Control Panel was not empty, instead there were boxes for every device with name but without items.

After a clean install with purge the items are shown again, but I get always a “Error 500 - Internal Server Error” when switching to Control Panel. Also at yahoo weather and FRITZ!DECT 200 the unit identifiers (W, kWh, °C, hPa, %) are missing. OS is Ubuntu 16.04.2 LTS.

From chrome developer window:
GET http://odrod:8080/rest/items?recursive=false 500 (Internal Server Error)

Thx, that solved it for me :grinning:
Normally I never take a look into the PaperUI Control panel, just did that because of this post and realized it was empty …

FTR, has been fixed and the fix is already available in the latest distro (#927).

1 Like

latest from today fixed the issue for me


control panel is back

Good to hear. :+1:

There must’ve been some use cases other than the Uninitialized thing that resulted in the same symptom.