PaperUI "Control" empty (Snapshot #925)


im on latest Snapshot, and since some days the “Control” Panel is empty. No Locations, no Things, nothing.

It was working fine, not sure if its the snapshot version, also tried some previous snapshots.

I assume some caching problem or something like this, tried reinstalling paperui panel.
is there any way to reset it ? or how to fix this problem

Hi, which snapshot build number are you using now?
On Linux/Windows?

Same here.
I am on Linux running the snaptshot 925 from yesterday 23.05:

Also the mobile App does not show anything. Logfile looks good, rule & items etc. are being loaded.

its build 925 from yesterday.
it was also on 924.
running on ubuntu

how to debug it ?, there is nothing in the logs

I also updated today from 924 to 925 but I haven’t experienced any problems…
It may take some time (few minutes on my rPi3) after first service start for the UIs to come up

What is the output of your java -version command?

Also, try to start up OH2 by using /usr/share/openhab2/ to see if any additional info comes up.
First: systemctl stop openhab2 and then

java version "1.8.0_131"
Java™ SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot™ 64-Bit Server VM (build 25.131-b11, mixed mode) output

0.202 ****** ERROR ALLJOYN_JAVA external     ...a/jni/alljoyn_java.c                                                                                          c:5517 |  0x9095
   0.283 ****** ERROR ALLJOYN_JAVA external     ...a/jni/ |                                                                                            0x9095
   0.305 ****** ERROR ALLJOYN_JAVA external     ...a/jni/ |                                                                                            0x9095
   0.323 ****** ERROR ALLJOYN_JAVA external     ...a/jni/ |                                                                                            0x9095
   0.687 ****** ERROR ALLJOYN_JAVA external     .../jni/ |                                                                                            0x9032

I cannot replicate.
I have 2 machines, both running Debian (a regular Jessie and a Raspbian) with OH2 Snapshot 925 and they run fine…

It could be something specific to Ubuntu (and it’s packages) ? … (I don’t know)

You could try Zulu JVM to see if it helps…

Changing the JVM won’t make any difference.

All reports here seem to have DIFFERENT problems. One has no Paper UI, the other an empty page on it, yet another ALLJOYN errors during the startup…

Log files will help and also a check if the Paper UI bundles are correctly installed:

openhab> list -s |grep paper
178 | Active   |  80 |     | Eclipse SmartHome Paper UI, Fragments: 181             | org.eclipse.smarthome.ui.paper
181 | Resolved |  80 |     | openHAB Paper UI Theme Fragment, Hosts: 178            | org.openhab.ui.paperui

Also clearing the browser cache might help.

FTR: Like @Dim I am running #925 without any issues.

1 Like

zulu does not fix it, same errors.
openjdk version "1.8.0_131"
OpenJDK Runtime Environment (Zulu (build 1.8.0_131-b11)
OpenJDK 64-Bit Server VM (Zulu (build 25.131-b11, mixed mode)

openhab> list -s |grep paper
205 | Active   |  80 |     | Eclipse SmartHome Paper UI, Fragments: 225             | org.eclipse.smarthome.ui.paper
225 | Resolved |  80 |     | openHAB Paper UI Theme Fragment, Hosts: 205            | org.openhab.ui.paperui

the active version is a different one, howto update ?

Just checking some stuff: Can you post the contents of your /var/lib/openhab2/etc/ ?

The online-repo should be set to

Also, Access Remote Repository should be enabled in your system.

You could try the following (warning: this is a hack… take caution :slight_smile:)
stop OH2
Delete files
Start OH2 and let it download and install from the online repo the latest versions of the jars…
(or grab them manually from here: Link1 Link2)

I have no clue what is the root-cause of your problem and I don’t really recommend hacking the installation to fix it…

The best method in these cases is to collect as much as logs as possible and provide them here for troubleshooting. If an issue will be identified, then you can open it on or

/var/lib/openhab2# ls
cache                           hs_err_pid10501.log  hs_err_pid1294.log   hs_err_pid14276.log  hs_err_pid21324.log  hs_err_pid24378.log  hs_err_pid30168.log  hs_err_pid5935.log  kar           uuid
config                          hs_err_pid10684.log  hs_err_pid1298.log   hs_err_pid16145.log  hs_err_pid22206.log  hs_err_pid2532.log   hs_err_pid3146.log   hs_err_pid6510.log  log           zwave  hs_err_pid11929.log  hs_err_pid1299.log   hs_err_pid17182.log  hs_err_pid2231.log   hs_err_pid26534.log  hs_err_pid3394.log   hs_err_pid7314.log  logs  hs_err_pid1271.log   hs_err_pid1325.log   hs_err_pid18444.log  hs_err_pid22407.log  hs_err_pid28179.log  hs_err_pid4141.log   hs_err_pid8656.log  openhabcloud
etc                             hs_err_pid1288.log   hs_err_pid13313.log  hs_err_pid20514.log  hs_err_pid23457.log  hs_err_pid28362.log  hs_err_pid4593.log   hs_err_pid9703.log  persistence
habmin                          hs_err_pid1293.log   hs_err_pid13436.log  hs_err_pid20780.log  hs_err_pid23719.log  hs_err_pid2841.log   hs_err_pid5028.log   jsondb              tmp

Access Remote Repository = enabled

online repo /apt installation

deb unstable main

there is no mvn folder in /var/lib/openhab2/tmp

/var/lib/openhab2/tmp# ls
fileinstall--1315759828953506607  fileinstall-526973083633793448    fileinstall-8760767702239644591  +~JF187298052308590969.tmp  lock
fileinstall-1324616689927387329   fileinstall--5318589733796394106  fileinstall-8791834469562396671  +~JF4031200844208874008.tmp  port
fileinstall-1565911574658559057   fileinstall-5670050280058858528   fileinstall-8846828515885678330  +~JF4187070621274507024.tmp
fileinstall--1846204876216624029  fileinstall-618719013881797219    heapdump2967668878849833712.txt  +~JF6255310971428367688.tmp
fileinstall--2061307366987014520  fileinstall-6966870167197652751   heapdump5492076768579768329.txt  +~JF6800321892823873300.tmp  libNRJavaSerial_openhab_0
fileinstall-3842488087353493973   fileinstall--8471583100479590239  +~JF1850376365868688400.tmp                    libNRJavaSerial_root_0

That’s correct for the /etc/apt/sources.list.d/openhab2.list file for apt-get commands (update/upgrade)

What about the entry for the online repo for addons on /var/lib/openhab2/etc/ (should be:

Something else is wrong then and it’s not being created…

I am lost :frowning: I don’t know what to suggest :stuck_out_tongue:
Maybe post some of the contents of the fileinstall-[...] and/or hs_err_pid[...] files?

what about flushing tmp folder ?

fileinstall folders are all empty

To eliminate this possibility: Check permissions, available disk space, and similar stuff that would prevent openHAB2 to create the /var/lib/openhab2/tmp/mvn directory and subsequent subdirs within that…

permissions are ok openhab:openhab
diskspace also.

i have just cleared tmp folder
and this is the result after oh2 start

/var/lib/openhab2/tmp# ls
fileinstall-8738955009357315628  libNRJavaSerial_openhab_0  lock  port

btw this is

openHAB Distribution Version Information
build-no        : Build #925
online-repo     :

Repository        Version
openhab-distro  : 2.1.0-SNAPSHOT
smarthome       : 0.9.0-SNAPSHOT
openhab-core    : 2.1.0-SNAPSHOT
openhab1-addons : 1.10.0-SNAPSHOT
openhab2-addons : 2.1.0-SNAPSHOT
karaf           : 4.0.8
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007fb530f41274, pid=1271, tid=0x00007fb537064700
# JRE version: Java(TM) SE Runtime Environment (8.0_131-b11) (build 1.8.0_131-b11)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.131-b11 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  []  JBusAttachment::Disconnect()+0x4d4
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

and also

is existing from the update yesterday timestamp

there is this in latest hs_err_pid log

I am out of ideas… I think that we need a more expert troubleshooter to help us here :slight_smile:

I tried to google the C [] JBusAttachment::Disconnect()+0x4d41 but I couldn’t find anything useful…

Which bindings are you using? Maybe try to uninstall them to see if this helps…

Also: can you get into the console or OH2 doesn’t get that far?

yes karaf console etc. is working, i just realized that “Control” in paper ui is empty.

i see just right now, there must be something else wrong.
also the log files in /var/lib/openhab2/logs
latest written on 22.05.2017 20:58:56
no newer entries.

all the automatic is working fine :slight_smile: rules sitemaps, also habpanel
log:tail in console has output

interesting… so OH2 is (partially) working but it seems that it is not writing stuff to the file-system ? (example: logs and temp)?

I would invite Kim here to do a complete re-install of the OH2 Snapshot (backup configs, apt-get purge and then install) :slight_smile:

just did it :slight_smile:


apt-get purge openhab2*
install latest snapshot

restored the files
same issue :slight_smile:

there must be something within these restored folders

just also purged oracle-java8-installer and installed again, same issue

Can you skip the /var/lib/openhab2/ dir from your restore? (Put back only only /etc/openhab2/)
You will lose jsondb, habpanel and other configs like this.