PaperUI "Control" empty (Snapshot #925)

i just reinstalled again with purging before
restored nothing.
and added 3 allplay speakers
“control” panel is empty like before
tried on diff. browsers and pcs + mac.
but mvn folder with its content is build now

Then it seems to be some issue with the binding.

The same error that you got is discussed in the thread above

I’ve seen this happen if I have Things that are in “Uninitialized” state (like when the binding for those Things is stopped). When I deleted those things, everything in the Control panel showed up again. YMMV

so i have restored files again, removed all bindings, just yahoo weather, network, z-wave binding is installed. and removed related things
but no control panel

the control panel was working before some days, not sure when exact i opened last time.
i have added some things in past days, so maybe there is one thing which cousing the issue.

but still dont find a way to debug the panel while opening control panel

@mhilbush there is no uninitialized thing

Oh well, it was worth a shot.

I’m also on Ubuntu and just updated; no issues whatsoever.
Maybe you have added an item which has an “%d” in it’s label?
This created the same issue for me a while ago.Replacing all “%d” with “%s” solved this issue for me.
There are some threads about this issue as well…

I had also a broken Control Panel after upgrade. But the Control Panel was not empty, instead there were boxes for every device with name but without items.

After a clean install with purge the items are shown again, but I get always a “Error 500 - Internal Server Error” when switching to Control Panel. Also at yahoo weather and FRITZ!DECT 200 the unit identifiers (W, kWh, °C, hPa, %) are missing. OS is Ubuntu 16.04.2 LTS.

From chrome developer window:
GET http://odrod:8080/rest/items?recursive=false 500 (Internal Server Error)

Thx, that solved it for me :grinning:
Normally I never take a look into the PaperUI Control panel, just did that because of this post and realized it was empty …

FTR, has been fixed and the fix is already available in the latest distro (#927).

1 Like

latest from today fixed the issue for me


control panel is back

Good to hear. :+1:

There must’ve been some use cases other than the Uninitialized thing that resulted in the same symptom.