Password for root access in Karaf console

Hi all

I am trying to reactivate TLS v1 in OpenHab 3.3.0 on my freshly installed OpenHabian on RPi4, in order to be able to activate the binding for IHC/ELKO controller interface. I found a topic here that guides how to reactivate TLS v1, but i am stuck when trying to get root access.
I establish SSH connection from Terminal in OS X, using “ssh -p 8101 openhab@IP”
I get access with standard password “habopen”, and then when i try to access root by typing “sudo -su” i am asked a password. I have tried Karaf standard password “Karaf”, “habopen” openhabian… nothing works.
What am i doing wrong here:
openhab> sudo su-
Password: *******
Error executing command: login failed

I appreciate your help, Thanks!

The ssh running on port 8101 is not the operating system. That’s a shell running inside of openHAB. There’s not such thing as root there. See The Console | openHAB. sudo isn’t something you’d do inside the karaf console (I’m surprised it didn’t just throw an error honestly).

Are you sure you are not supposed to be on the host OS’s shell, which runs at the default port of 22?

Hi Rich Koshak

Thank you for your reply! Good point - It makes sense to me!
I tried to log in via port 22 to get access to the OS shell, but i have no success in guessing the password. I have tried combinations with openhab/habopen, openhabian/openhabianpi etc. It says
“Permission denied, please try again.”

Do you know what standard password i can use?

I am trying hard to follow Wolfgang_S’s instruction below


  • ssh into your raspi: ssh openhabian@openhabianpi
  • become root: sudo su -
  • cd into the directory: cd /opt/jdk/zulu11.48.21-ca-jdk11.0.11-linux_aarch32hf/conf/security
  • make a backup copy: cp
  • open vi editor: vi security
  • search for TLSv1: /TLSv1,
  • your cursor should be on T of TLSv1, in the line that you showed before; if not hit key n; if stil not :q
  • you are on TLSv1,: enter dw two times
  • the string TLSv1, should be deleted now
  • if exactly that part is deleted and you have …SSLv3, TLSv1.1,… hit :wq
  • file should be saved now and you should be back on the command line

According to the docs

When openHABian has installed and configured your openHAB system, you can start to use it right away. Connect to your Raspberry Pi SSH console (opens new window)using the username openhabian and password openhabian .

This of course assumes you didn’t change it.

Yes - it works! You just made my day! I for some reason missed that chapter when reading thru the documentation