Permission changed on samba?

Hi There,

Im running openhab on a Rpi3. Yesterday I did an update on the installed packages through openhabian-config.
Now I cant access the samba folders through my windows 10 laptop.
The laptop asks for a username and password, but the standard ssh user and password seem to be wrong.

I can get access through SSH and openhab:8080 is working completly.

Besides that I don’t know what changed the permissions, does anyone know how to fix it?



Ow by the way. I’m a bit confused here. With SSH I log in with user OPENHABIAN.
But that user isn’t stated in the user list from the screenshot above.

I changed permission to openhabian with chown for OPENHAB_CONF, but no result.

I can get into the top folder, but not into the sub folders

I suspect you booted your box?
See if sudo systemctl status smbd tells you that Samba is down, it sometimes fails to startup.
If so use sudo systemctl start smbd .

Which is fine because openHAB runs as user openhab (only).

Bad idea. Use openhab-cli reset-ownership to change it back.

Hi thanks for your reply.

Samba is running (otherwise I wouldnt be able to get into the top directory I guess.


openhab-cli reset-ownership

But same result
Trying to get into ‘openhab-conf’ and my PC will ask for permissions. And user openhabian isnt recognized

This is very strange, but I installed a samba app on my android phone and I can access the shares from there.
So must be something with my laptop, but what…

Assign the samba share folder to a free drive letter in WIN10. Then it should work.
I think I had the same problem in the beginning.

Windows keeps asking me to log in, but refuses connection.
I can still get into the top level directory, but cant get into openhab-conf.

Removed all known credentials from windows to the raspberry, but still no permission to enter the folder

As @HolgerL mentioned, “assign the samba share folder to a free drive letter in WIN10.”

That is not neccessary and shouldn’t have any effect. Using an UNC path or a drive letter doesn’t matter for explorer access. Other windows applications may differ.