Philio PAT02-B celsius

Hy guys,

I have trouble setting the above device to Celsius. I’m on the latest snapshot build with the new zwave binding. Parameter 5 Operation mode is set to 33 by default and is apparently controlling this. Bit 3 is supposed to be set to 1 for celsius reporting. But how do I set it?

Would I just type the decimal value corresponding to the bit setting? So let’s say 8 if I just want to set bit 3 to 1? Counting starts at bit 0.


Yes, set the value to 8.

Note though that if you are on the latest snapshot, this won’t help as the system will convert the units using the UoM system, which depends on how you have the regional settings configured.

Mhm, interesting. I actually configured everything to my location just missed the units. I did now set it to SI Units and will try this first.

Shouldn’t need a restart correct?

If the bit numbering method is MSB add 16 (if LSB 8) to the value.

There is a standard definition in ZWave, so unless this device breaks this it will not be this way around.

I don’t think so, but I’m not 100% sure.

Are you using the latest 2.4 snapshot binding? If you are on 2.3 then this won’t be applicable.