Philips LTA001 bulb; dimmer and colortemperature: no reaction on bulb

Thank you for most excellent help and info.
I found the sniffer pdf to be very good and that helped me to get a initial grasp of zigbee communication.
I would be totally lost if it was not for the filtering tips.
The coloring helped too, to sort out the more important bits.

Just let me know if you want me to test something.

Great.
:smiley:

I just gave this a quick try using my debug system, and it joined ok. This isn’t exactly the same as the binding, but all the ZigBee code is the same. Also, it’s not an LTA001 - it’s an LWA001 (not sure what the difference is!).

Maybe it’s an issue with the firmware - I’m a bit hesitant to just dig out some random firmware in case you brick your device. What OS are you using? I have one of these here but it doesn’t work on a Mac but I might see if my linux system discovers it a bit later - I’d be happier if I could test it here before sending you something :wink: .

Node Info             Value
Application Version   2
Date Code             20190122
Generic Device Class  0
Generic Device Type   255
HW Version            1
Manufacturer Name     Philips
Model Identifier      LWA001
Power Source          1
Product Code          ByteArray [value=]
Product URL           www.meethue.com
SW Build ID           1.53.3_r27175
Stack Version         1
ZCL Version           2

Debian Buster on a Intel NUC so amd64 architecture for my openhab machine.
Debian Buster (and some) on my laptop.

Great,
I do have two of the bitronvideos, so not a big deal if one goes kaput :slight_smile:

So, the problem is with the Bitronvideo firmware? I have been investigating the web to update the firmware, some information found on the Home Assistant forums, but I didn’t find a proper ans secure way to do that. Any help on this will be appreciated.

Yes, there was another thread with someone with the same problem; bitronvideo and hue.

I never found the time to follow up on this, and I have the impression that @chris was even more busy :slight_smile:
So, mybe the time is right :slight_smile:

Can I just check if you ever found a solution to this? I am having what I think is a similar issue with a Hue Bulb LTG002 and this Ember controller (ZB-Stick (701554) - popp.eu) based on SiLabs EFR32MG1

When I put the controller in scanning mode, the bulb goes ONLINE and can be controlled fine from OpenHab (responds to dimming etc.). After a few seconds, the bulb goes back OFFLINE. ONLINE and OFFLINE refer to the state from the openhab console command “zigbee nodes”.

You can see in the log attached at 23:38:13.287 it goes “DEVICE_LEFT”
logextract.log (41.1 KB)

I am assuming this is a similar issue and would really appreciate tips for solving it.

Can you give us a clue what system you are using please? OH2 or OH3 as I thought this was resolved on newer bindings by updating the default join configuration.

Thanks Chris, I am on OH 2.5.12 which I understand is the latest 2.5.x version

I can give this a go later tonight.
I have not tried this Hue bulb since I upgraded to OH3.
But I tried a zigbee v3 certified Apex smart switch that seemingly behaved just like the Hue bulb.

I have tested many Zigbee 3 devices, so this is clearly not an issue with zigbee 3.0 and we have a lot of customers using the system with zigbee 3.0. Z3.0 support was originally added for Deutsche Telekom about 3 years ago… Without logs to see what is happening it’s pretty difficult for me to comment - and also a bit hard I think for you to say what is happening?

Logs are coming :slight_smile:

Thanks. Please note that join issues require the sniffer logs - not binding logs since this is not a binding function.

I can report (happily!) that upgrading the firmware on my Popp ZB-Stick to version 6.7.0 seems to have fixed this issue (GitHub - Elelabs/elelabs-zigbee-ezsp-utility: Elelabs Zigbee EZSP Utility to perform firmware update on a range of Elelabs EZSP products as well as other generic EZSP adapters.)

2 Likes

I finally got time to sit down and sniff 3 different devices;
The above mentioned Philips LTA001 bulb, a Phillips Hue Outdoor Floodlight and the Apex smart switch.
They all decide to leave the network.

Chris, do you still want to see the sniffer pcaps?
I getting more and more sure that my problem is the firmware in the Bitronvideo stick.
tinaught’s findings with firmware update build up on that.
@tinaught Do you know what firmware you had before the update?

For the record:
Debian Buster on a Intel NUC
openahab 3.1.0~S2243-1
Bitronvideo BV2010/10 Coordinator

openhab> openhab:zigbee ncpversion
Ember NCP version 5.8.0.0, EZSP version 4

I have the new Itead/Sonoff stick in the mail, but it will be a week or two before they get here.

My guess is that your dongle is just too old. 5.8 is very old now - the current release is 6.9.

@NilsOF the old firmware that came with the stick was 6.0.3-64

1 Like

The Popp stick looks nice, where did you get the firmware?
Edit: Oh, there is firmware in the github repo you linked to above,
I guess you used that one?
I probably get one as it have a casing. The Itead do not…
:slight_smile:

A quick test with a Itead/Sonoff EFR32MG21 based USB stick:
Both the Philips Hue LTA001 bulb and the Apex smart switch work just fine.
The Itead/Sonoff stick have firmware version 6.7.8.0.
So, I conclude that the Bitronvideo 2010/10 just have a too old firmware version.

1 Like