PI4 B 8gb RAM

  • Platform information:
    • Hardware: _PI4 B 8gb
    • opnehab _latest imge installed 64 bit = openhabian-pi-raspios64beta-202007302224-git0290f04-crc93729328.img
    • Issue of the topic: Can SSH but can not HTTP into openhab

I have seen some posts with the PI4 with 8gb of ram but my issue is:

I bought the PI4 B 8gb, loaded as normal the production image but had so many issue like hanging, not booting and finally could ssh but no UIs. I called got a replacement thinking the unit was defective now same issue. So research several hours now loaded the above 64 bit image, loaded fine, ssh OK but still can not web into it. Took my SD from my home system (PI4 B 4gb) placed it in the new PI same issue, I can not web into it.

Any help would surely be helpful for me to keep what hair I have left…

SSH into pi

Which Kernel is installed?
hostnamectl | grep Kernel

If its not Kernel: Linux 5.4.51-v8+

Look at the first-boot.log
cat /boot/first-boot.log

ZRAM probably failed to install.

open menu

sudo openhabian-config

Under 30 system settings Uninstall Zram

God made a couple of good looking heads and put hair on the rest of them.

I have loaded several images, to now find out I can ssh is just fine, but the web access doesn’t work. I just discovered if I use “sudo openhab-cli start” then I can get into “openhab:8080” to work But “openhab viewer UI” still doesn’t work, for example. Please understand I am not programmer but I have been using Openhabian for 2 years now and have a fair home automation system. I have 2 new PIs 4 B with 8gb that reacts the same. It appears the Openhabian images need some help with regards to this new PI. My basic question does anyone have a new PI 4 B with 8gb working with what image? ZRAM appears ok based on the ssh splash screen.

That is not the correct way to start oh and it may give you more headaches.

I am the same as you not a programmer.

Use this image https://github.com/openhab/openhabian/releases/download/v1.6-alpha/openhabian-pi-raspios32-202007302224-git0290f04-crcd2852e99.img.xz

Edit the openhabian.conf file before you put it in pi
Use notepad on windows.

Add line


Save and eject sd card
After putting it in pi wait for ages

Thank you denominator, I used that image I just didn’t edit the config file. I will do this tomorrow and let you know. Frustrating when only increasing RAM can cause so much havoc.

Sorry denominator, did as you suggested 2Xs. Same problem, web services doesn’t work until I run “sudo openhab-cli start” but I want to say this doesn’t fix all the problems, just access to UI. Another interesting function. Using ssh, openhabian-config, I installed 21 - log viewer, then the PI rebooted. Geezz

in the openhabian config try uninstalling zram in system settings

also to start openhab use systemctl

sudo systemctl start openhab2.service

Also double-check that clonebranch=master

1 Like

I loaded Raspian and it works top notch, but I will miss my Openhab, hope the image get adjusted soon. I want to upgrade my home ‘openhab’ system. I can wait a little longer. Thanks guys for the help.

You meant to say you loaded Raspbian and do not use ZRAM right?
The crash issue is not in openHABian but in Raspbian, but it only surfaces when you enable ZRAM which has advantages but is not a must.
So why don’t you just disable that as @denominator and I told you to (see above).
You can still add it later when the kernel issue gets resolved.

OK I will, I am just worn out from the hours of trying to find the cause, buying a second PI because I thought I had defect hardware. My thought if we know this is an issue for the 8gb PI then could we just make ZRAM an option to be added in Openhabian-config for dummies like me? As it is there, just don’t make it active per default? THANK YOU for all your help!!!

openHABian already skips installing ZRAM on a RPI4/8GB. You have to use the master branch though.

Good information thanks, but I do not know “the master branch” Told ya I was a dummy…

Even a dummy can read the docs can’t he ? Or the text of menu option 01 ?

OK did as instructed above, left it on all day, got home the green led 4 long flashes, then 4 short flashes the repeats, rebooted nothing. I give up.

Model 4 (B) green LED blinks regular when the PI doesn’t detect the SD-card

Thanks for trying because they are only very new and @mstormi probably dosen’t have the hardware to test, it can take a while to debug every issue.

When you read the docs you will have noticed there’s a Debug guide.
As already mentioned you’ll need (at least) clonebranch=master in openhabian.conf.

1 Like