Pilight binding installation

I wanted to install the pilight binding, but it’s not available for install via PaperUI.
I found the plugin description HERE but it doesn’t have any installation instruction…
Then I found this old plugin HERE but I didn’t find any instruction how to install this in OpenHAB2, and I don’t find the jar anywhere in the repo.
Can someone help to install this?

1 Like

I’ve been using pilight for quite some time now. Keep in mind that it appears that the development around pilight has stopped. There are some reports that pilight may not work anymore on the latest Jessie updates (if you run it on a raspberry). I cannot confirm this as I have a dedicated raspberry for pilight and fearing exactly that (that an upgrade can break pilight), I have not upgraded that raspberry for 1 year or more.
If you find the OH1.8 jar (sorry don’t remember the link), you can just drop it in your addon folder. You will have to create a configuration file too, the format and explanations are on the wiki for OH1.8.
PaperUI will NOT support this binding, not will you be able to discover things. Neither can you install it through the repo, it will always be a manual install, the jar will stay if you do upgrade through apt-get; but if you rebuild your system you will have to go through the manual installation again.

But you can access the pilight OH1.8 binding through your item definition. To get you started here my pilight.cfg file (for OH2):

# IP address of the pilight daemon
# Port of the pilight daemon
# Optional delay (in millisecond) between consecutive commands.
# Recommended value without band pass filter: 1000
# Recommended value with band pass filter: somewhere between 200-500

here my item definitions:

Switch  LivingroomLamps    "Living Room Lamps" (gLights,gLightPanel,gEveningLightsON) ["Switchable"] {pilight="kaku#LivingroomLamps"}
Switch  BedroomLamps    "Bedroom Lights" (gLights,gBedtimeLightsON,gLightPanel, gEveningLightsON) ["Switchable"] {pilight="kaku#BedroomLamps"}

Edit: and pilight always throws an NPE error during startup, nothing to worry about, but just so you know, it does for me not have any functional consequences.

Personally I have just moved everything to wifi plugs (I had only plugs), because I felt it was time to move on.

Quite a few people here use the Intertechno binding to access their 433Mhz devices/plugs; maybe that would be a more future proof approach. There is also a MySensor binding on the works (and on the Eclipse Marketplace).

Thanks for the detailed anser :slight_smile:
Is there a maintained alternative to Pilight that you know of?
You said that you moved to wifi power switches, I also thought of that but everything I found talks to some dubious servers in China and has crappy Android apps that want way too many privileges… Which can you recommend that are OpenHAB-controllable and don’t talk to any dubious servers? That would really help me :slight_smile:

for the 433Mhz, you may want to look at Intertechno. there is a binding for it, and if you want to can also sent raw data that will allow you to work with a lot of other brands (but require more knowledge).
For wifi plugs, wemo, z-wave and some others are supported by a binding, I have TP-links HS100, just because they are cheap; a binding for those is in a nascent state but you can use a shell script on linux to poll the status and switch them on and off: https://github.com/ggeorgovassilis/linuxscripts/tree/master/tp-link-hs100-smartplug
those you can keep local (or create an account and have access from outside), I kept them local.
Zwave is all yours too if you want.
hope that helps

and just if you really want to go with pilight, you can get the latest binding from here:
courtesy of @Udo_Hartmann:

The HS100 aren’t cheap in opinion :confused:
30€ for one wifi plug VS 17€ for three 433mhz plugs (plus a remote), I think I’ll try to get pilight to run, thanks to you I got some pointers now :slight_smile:

Unfortunately, no luck here with latest bundle builds for me. 1.9 loads and connects, but the items are not updated. This used to work. I can’t see any errors when trying to put 1.12 in the addons directory. Don’t know how to debug that further.

sigh, I am such an idiot… my sensor had changed its ID due to a reset, so I no longer saw it. pilight binding 1.9 was working fine, I just did not realise it. here is a link to the build that is working for me - https://drive.google.com/file/d/1UFnk1kcRM_yydJkOqTefEY8SqFx6FIb3

I don’t have an original link.

I also double checked and 1.12 binding was still not working (does not even connect to pilight). but that might be because my other pilight version (although 7 is not that old)


I also want to integrate pilight in order to receive the signals from my 433 Mhz remote and update items accordingly.
I tried the file you provided and also version 1.12 which should be the latest version.
My config and item looks like lipp_markus wrote in the second post.
I only see one entry in the logfile that the item was bound to pilight.
But no matter what I do, the item in openHab won’t update nor the log shows anything. In the pilight-gui, the switch works perfectly and changes when I press the button on the remote.

What else can I do now, or do you see any fault?

Hello, i had massive issues using the pilight binding with Openhab 2.2 as well. (Null pointer exceptions …) And tested several days. With the linked 1.9 snaphost version from these thread i got it working now.

I found out there is something strange in the migration guide. After removing all bindings from the addon.cfg under /etc/openhab2/services, i found out there is a second persistence /var/lib/openhab2/config/org/openhab/addons.config where my initially manual entered pilight module was stored. There i removed only the pilight modul entry (the other modules should stay consistent what you have installed via Paper UI).

The pilight binding (from https://drive.google.com/file/d/1UFnk1kcRM_yydJkOqTefEY8SqFx6FIb3) i copied to /usr/share/openhab2/addons where it was automatically found and used, visible in the openhab log.

With this adaption all my pilight related items configured in OH 1.8.3 runtime working properly now!

I also managed to solve my problem, see here: