PioneerAVR 2.0 issues

Hi all,

I took OpenHAB 2b2 for a spin today as the weather could be better :wink: . However, in the testing progress of required bindings I got stuck at the Pioneer binding. I am just using a clean install with the demo being loaded. The AVR is a Pioneer VSX-923, which runs on port 8102 (instead of the default 23 if I am correct)

So first up is the autodiscovery in Paper UI which seems to be kind of broken in my case for this binding. It discovers a Pioneer receiver in my network, but as an unsupported one. Which is true, as it is not in the list. However, when I add it as a thing I get this error in the log:
21:35:18.125 [WARN ] [e.core.thing.setup.ThingSetupManager] - Cannot create thing. No binding found that supports creating a thing of type pioneeravr:ipAvrUnsupported.

Hence, the second option is to add a supporter Pioneer IP controlled Thing through the paper UI instead. And indeed, a Thing shows up. However, the configuration panel only has an address field, which I fill with, the IP of my Pioneer AVR. However, it keeps reporting that the device is offline and indeed, it does not respond to any buttons. I guess the port config field is lacking here. Putting “” as address does not work either.

No worry, we can still configure the binding manually right? Hence I created a pioneeravr.things file with:
pioneeravr:ipAvr:vsx923IP [ host="", port="8102" ]
(as described in )

However, that gives me:
21:49:58.217 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'pioneeravr:ipAvr:vsx923IP' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_CONFIGURATION_PENDING)

And hence this method is also not working. So I am stuck with a non-working pioneer AVR binding here. I have no clue how (and if) I can resolve the HANDLER_CONFIGURATION_PENDING problem. I also followed the other topic and updated the binding as posted here: Pioneeravr binding - volume up/down

But also, this does not solve my problem

And just that moment I dive a bit in the Eclipse Smarthome documents to read what the error actually means I tried some last things: Namely changing the config to:
pioneeravr:ipAvr:vsx923IP [ address="" ]

Which fixes the problem for me, it is running now. However, I still believe that there are some bugs/problems with the binding and obviously, the documentation needs an update :wink:

I can confirm that in 2.0.0.b2 version of the binding (and my version you linked to) does not properly handle “ipAvrUnsupported” things - you can’t configure them from the Paper UI. I know how to fix this but I have yet to change the code to do so.

As for now, I am not running OH2 (still running 1.8) and just did a little hacking on the Pioneer AVR binding to get familiar with the new architecture + development environment. In the near future, my plan is to setup an RPi2 with OH2 so I can really start testing it.

Ok clear, thanks for the information. It may be wise to update the old binding to make it OpenHAB 2.0 compatible as a legacy alternative if people have issues with the 2.0 binding. See this PR, for which the Pioneer binding was excluded due to the existence of a 2.0 binding:

(I comfirmed that the 1.8.1 binding indeed does not work properly with OH2b2)


I have fixed the ipAvrUnsupported creation issue, updated the binding documentation and fixed the port configuration in PaperUI with this PR:

Hi guys,
I have the problem that the power off signal for my VSX-923 working fine. But when I try to power on the device it doesnt work. I just modified the steps according the github example with my ip and everything other looks like on this example. The only other problem is as well when I push the signal input button there nothing happens. I cant change the HDMI or whatever over papier UI or HABpanel.
Is there something more needed to change that these two functions working as well?


For the power on issue, can it also be the power-saving setting on the AVR? I have a VSX 921, and there is an option Network standby, when it is off then network is not active when powered off. Guest you might have already checked this one, but just to be on the safe side :slight_smile:

Amazing… thanks for your tip… that was is. Exactly :wink:
Now I just have to solve my other issue…

This is my actually sidemap

sitemap demo label="Main Menu"

Frame label=“Pioneer AVR” {
Switch item=vsx921PowerSwitch
Switch item=vsx921MuteSwitch mappings=[ON=“Mute”, OFF=“Un-Mute”]
Slider item=vsx921VolumeDimmer
Setpoint item=vsx921VolumeNumber minValue="-45" maxValue=“5” step=“0.5”
Switch item=vsx923InputSourceSet Label=Input List mappings=[25=“BD”, 05=“TV/SAT”, 06=“TV/CBL”, 19=“HDMI 1”, 20=“HDMI 2”, 21=“HDMI 3”, 15=“DVR/BDR”, 44=“Media Server”, 17=“iPod/USB”, 02=“TUNER”, 12=“MULTI CH IN”, 57=“Spotify”]
Text item=vsx921InformationDisplay

I have a Pioneer XC-HM81 Micro-Hifi-System and use the Pioneer AVR binding (binding-pioneeravr - 2.5.2) for controlling it remotely via network. The command set of this system is very limited, but at least it is possible to control power, mute, volume up/down (no numbers, only VU/VD), source selection via telnet.
With the binding i am able to switch the box on/off and un-/mute. But increase/decrease the volume with the binding fails.

This is my current items-configuration which is working for power and mute. It is also possible to receive the actual volume value, but increasing/decreasing volume won’t work.

Switch   XCHM81_Zone1Power                             "Zone1 power"                               {channel="pioneeravr:ipAvrUnsupported:xchm81:zone1#power"}
Switch   XCHM81_Zone1Mute                              "Zone1 mute"                                {channel="pioneeravr:ipAvrUnsupported:xchm81:zone1#mute"}
Number   XCHM81_Zone1VolumeDb                          "Zone1 volume db"                           {channel="pioneeravr:ipAvrUnsupported:xchm81:zone1#volumeDb"}

In my sitemap I tried following configurations

Switch item=XCHM81_Zone1VolumeDb mappings=[ON="Vol+", OFF="Vol-"]
Switch item=XCHM81_Zone1VolumeDb mappings=[INCREASE="Vol+", DECREASE="Vol-"]
Switch item=XCHM81_Zone1VolumeDb mappings=[UP="Vol+", DOWN="Vol-"]
Setpoint item=XCHM81_Zone1VolumeDb step=1 minValue=-80.5 maxValue=0

Following warning messages are thrown in the Log Viewer after the respective vol+/- buttons are pushed in the basic ui:

[WARN ] [rest.core.internal.item.ItemResource] - Received HTTP POST request at 'items/XCHM81_Zone1VolumeDb' with an invalid status value 'ON'.
[WARN ] [rest.core.internal.item.ItemResource] - Received HTTP POST request at 'items/XCHM81_Zone1VolumeDb' with an invalid status value 'OFF'.

[WARN ] [rest.core.internal.item.ItemResource] - Received HTTP POST request at 'items/XCHM81_Zone1VolumeDb' with an invalid status value 'INCREASE'.
[WARN ] [rest.core.internal.item.ItemResource] - Received HTTP POST request at 'items/XCHM81_Zone1VolumeDb' with an invalid status value 'DECREASE'.

[WARN ] [rest.core.internal.item.ItemResource] - Received HTTP POST request at 'items/XCHM81_Zone1VolumeDb' with an invalid status value 'UP'.
[WARN ] [rest.core.internal.item.ItemResource] - Received HTTP POST request at 'items/XCHM81_Zone1VolumeDb' with an invalid status value 'DOWN'.

[nt.ItemStatePredictedEvent] - XCHM81_Zone1VolumeDb predicted to become -53
[vent.ItemStateChangedEvent] - XCHM81_Zone1VolumeDb changed from -54.0 to -53
[vent.ItemStateChangedEvent] - XCHM81_Zone1VolumeDb changed from -53 to -54.0

Is it actually possible to send the VU/VD commands with this binding version and if so, how can I do this?