Playing anything on audio sinks: TTS

  • Platform information:
    • Hardware: RPI 4
    • OS: Raspbian
    • Java Runtime Environment: 11
    • openHAB version: 3.0

I’ve tried to set up Google Cloud TTS and completed every configuration step, but nothing was working. So I tried to start from the beginnings and I trying to play mp3 using default audio (Chromecast Google Mini)

I want to playSound inside rules, so I try to test it using openhab-cli:

  1. My default speaker is setup:
    openhab> openhab:audio sinks
* Chromecast: Google Home Mini (chromecast:audio:google_mini)
  System Speaker (enhancedjavasound)
  Web Audio (webaudio)
  1. I try to play local file (located under /etc/openhab/sounds/doorbell.mp3) I have permission to do that.

openhab:audio play doorbell.mp3

Nothing is playing, but I can play the same file using Chromecast binding (different file location to make it accessible from browser):

Does anyone have any ideas? I spent already a few days trying to figure it out.

PS. I can’t see any entries inside log files related with that

It looks like audio stream url is working, but audio play localFile is not, as well as audio stream localUrl is not working.

Did anyone experienced something similar?

I have an similar problem, and no answer