PlaySound working fine, PlayStream not

Tags: #<Tag:0x00007fc1f96b4870>

Hi,

I have following rule in order to play sounds:

rule "select Radio Station"
when
Item radioStationSelector received command
then
switch (receivedCommand) {
case 1 : playStream(“http://metafiles.gl-systemhaus.de/hr/hr3_2.m3u”)
case 2 : playSound(“doorbell.mp3”)
}
end

And an item radioStationSelector in HabPanel.
If I choose 2, the sound of the local mp3 plays fine (using webaudio on my client), so my sound works.
However, if I choose 1, nothing happens. What I’ve done so far:

  • Tried many other streaming URLS, including mp3, m3u, M3u8, but nothing works
  • checked logging, but this shows no errors when activating case 2
  • Tried alternative clients such as my smartphone and ipad, but same result there

Any idea what this can be related to?

no-one any idea?

Could this be related to the fact that I run OpenHAB on my synology NAS? (although everything else works perfect: knx binding, weahter binding, etc…)

Hello, have you ever found a solution?

Nope, but I later switched from Synology to a raspberry pi, and the issue dissapeared.

Man may I ask you if you switching to a raspberry, using playstream with webaudio you managed to play a online radio to a client device?
I’m trying to achieve that and no success by now, I’m able tho to play audio via webaudio.