Plex Binding and new Plex Media Server with HTTPS bad request


I’ve been using the Plex binding. It was working a while ago and then I didn’t use it for a while, and then it broke. The Openhab log shows:

2015-09-28 11:14:17.345 [ERROR] [.b.plex.internal.PlexConnector] - Error while sending command to Plex: Bad Request

Bad Request

400 Bad Request

I finally figured that if I revert to Plex Media Server version 9.12.1, the binding works again. (Reverting just involves downloading the old version and running it. Old versions are here: I see that HTTPS was implemented from version 9.12.3, and that’s when the binding stopped working.

Is there an easy fix to get the binding working with HTTPS?

Does anyone know where in the binding code to change the request url to HTTPS?


If anyone could point me in the right direction to solve this, it would be much appreciated. I can’t run a downgraded version of Plex server because the iOS app stops working if I do. I have seen the same issue here:!topic/openhab/eSDfQO1RUpI
and here:

So it does seem to be affecting a number of people. I have also checked for any settings to try and disable https in plex server, but without any luck.



just ran into the same problem and created an issue on github for it.
Let’s hope it will get fixed.


I followed the link to Github and used the updated version and it does work for the record, at least with a Mac server and Home Theater.