Plex binding only working "Read Only"

Hi all,

I’ve been using OpenHab a while with mixed success - but this one has got me stumped…

I’m on the stable 2.4 build - using I’ve done this using separate installations on OpenHabian and Windows with the same result, I’ve tried against plex ( on both a Qnap and Windows - both with the same result. I have PlexPass.

So - I’ve followed the guide setting up Plex, it seems to connect and all is good.

I’ve even got the demo sitemap up pretty straightforward - and it updates as media is playing in Plex - so I know its working.

However - if I press any button - Say Pause for example - I see the event fire in OpenHab - but nothing happens in Plex. its like it can read - but not write.

Looking at the Logs on the Plex - it doesn’t seem to register that anything has been tried.

I had a Pin on my account in Plex - I’ve taken that off. I’ve also set the Plex servers to not require authentication locally by including the IP Address of the local subnet.

The Logs in OpenHab show authentication happening just fine, and it finds the Plex server - Updates as to what is playing, and its progress come through to the sitemap just fine.

I see no errors in /var/log/openhab2/events.log

2019-02-10 21:16:33.730 [vent.ItemStateChangedEvent] - PlexTVProgress changed from 63.57 to 65.69

2019-02-10 21:16:43.778 [vent.ItemStateChangedEvent] - PlexTVEndTime changed from 2019-02-10T21:19:15.588+0000 to 2019-02-10T21:19:15.628+0000

2019-02-10 21:16:43.790 [vent.ItemStateChangedEvent] - PlexTVProgress changed from 65.69 to 67.81

2019-02-10 21:16:52.741 [vent.ItemStateChangedEvent] - PlexTVEndTime changed from 2019-02-10T21:19:15.628+0000 to 2019-02-10T21:19:15.604+0000

2019-02-10 21:16:52.783 [vent.ItemStateChangedEvent] - PlexTVProgress changed from 67.81 to 69.71

2019-02-10 21:16:53.860 [ome.event.ItemCommandEvent] - Item ‘PlexTVPlayPause’ received command ON

2019-02-10 21:16:53.871 [vent.ItemStateChangedEvent] - PlexTVPlayPause changed from NULL to ON

2019-02-10 21:16:54.417 [ome.event.ItemCommandEvent] - Item ‘PlexTVPlayPause’ received command ON

2019-02-10 21:16:54.990 [ome.event.ItemCommandEvent] - Item ‘PlexTVPlayPause’ received command ON

2019-02-10 21:16:59.687 [ome.event.ItemCommandEvent] - Item ‘PlexTVPlayPause’ received command ON

2019-02-10 21:17:00.728 [ome.event.ItemCommandEvent] - Item ‘PlexTVPlayPause’ received command ON

2019-02-10 21:17:01.271 [ome.event.ItemCommandEvent] - Item ‘PlexTVPlayPause’ received command ON

2019-02-10 21:17:01.830 [ome.event.ItemCommandEvent] - Item ‘PlexTVPlayPause’ received command ON

2019-02-10 21:17:13.848 [vent.ItemStateChangedEvent] - PlexTVEndTime changed from 2019-02-10T21:19:15.604+0000 to 2019-02-10T21:19:15.717+0000

2019-02-10 21:17:13.904 [vent.ItemStateChangedEvent] - PlexTVProgress changed from 69.71 to 74.16

Any help appreciated.

Any luck? I’ve got the same problem. OpenHAB en Plex are connected successfully, I can read the status but I can’t send any commands.