Plugwise binding failing on Rasp

I am trying to get a plugwise stick to connect to my Openhab 1.8.0 installed on a Rasp.

I see the USB stick connecting to ttyUSB1 (dmesg) but the log shows the following:

2016-01-23 14:09:51.777 [DEBUG] [b.p.internal.PlugwiseActivator] - Plugwise binding has been stopped.
2016-01-23 14:09:53.347 [DEBUG] [.o.m.c.i.folder.FolderObserver] - Refreshing folder 'sitemaps’
2016-01-23 14:09:53.356 [DEBUG] [.o.m.c.i.folder.FolderObserver] - Refreshing folder 'persistence’
2016-01-23 14:09:53.365 [DEBUG] [.o.m.c.i.folder.FolderObserver] - Refreshing folder 'rules’
2016-01-23 14:09:53.379 [DEBUG] [.o.m.c.i.folder.FolderObserver] - Refreshing folder 'scripts’
2016-01-23 14:09:53.386 [DEBUG] [.o.m.c.i.folder.FolderObserver] - Refreshing folder 'items’
2016-01-23 14:09:53.630 [DEBUG] [b.p.internal.PlugwiseActivator] - Plugwise binding has been started.
2016-01-23 14:09:53.687 [DEBUG] [i.internal.GenericItemProvider] - Start processing binding configuration of Item ‘switch1 (Type=SwitchItem, State=Uninitialized)’ with ‘PlugwiseGenericBindingProvider’ reader.
2016-01-23 14:09:53.767 [ERROR] [inding.plugwise.internal.Stick] - Failed to initialize Plugwise stick: Serial port ‘/dev/ttyUSB1’ could not be found. Available ports are:

2016-01-23 14:09:53.774 [INFO ] [o.b.p.internal.PlugwiseBinding] - Plugwise added Stick connected to serial port /dev/ttyUSB1
2016-01-23 14:09:53.789 [ERROR] [b.plugwise.internal.CirclePlus] - Error scheduling a Quartz Job
2016-01-23 14:09:53.796 [INFO ] [o.b.p.internal.PlugwiseBinding] - Plugwise added Circle+ with MAC address: 000D6F000098E8C6
2016-01-23 14:09:53.799 [INFO ] [o.b.p.internal.PlugwiseBinding] - Plugwise added Circle with MAC address: 000D6F0000990954
2016-01-23 14:09:53.806 [INFO ] [o.b.p.internal.PlugwiseBinding] - Setting the interval to send ZigBee PDUs to 150 ms
2016-01-23 14:09:53.817 [INFO ] [.service.AbstractActiveService] - Plugwise Refresh Service has been started
2016-01-23 14:09:55.313 [INFO ] [.service.AbstractActiveService] - Plugwise Refresh Service has been shut down

Anyone any suggestions on how to resolve?

Do you have any solution to the problem?

On a Raspberry Pi you may need to restart the Pi before it properly detects/configures the Stick.

You can use the lsusb command to see if it has detected the Stick.

The stick will then show up as:

Bus 001 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

Once it is properly configured, you can check to which port it is connected using the command:

dmesg | grep usb

It should then list something like:

[    5.110715] usb 1-1.4: Detected FT232RL
[    5.111657] usb 1-1.4: FTDI USB Serial Device converter now attached to ttyUSB0

In this case you can configure /dev/ttyUSB0 as port for the Stick.

When you have multiple USB devices hooked up to your Pi, the USB port can change after each startup. That can be resolved by configuring a udev rule. This is described in the following openHAB wiki.

Also keep in mind that on Linux you may need to add the user running openHAB to the dialout group before openHAB can access serial ports. E.g. when you run openHAB with user openhab, execute the following command:

sudo adduser openhab dialout

The user may need to logout/login before the updated group permissions are granted.

See also the Plugwise Binding wiki where I have added most of this information.