Popp 012501 + OH2

POPE012501: zwave database entry isn’t complete. So I did try to include. A new node 9 added to my things. More isn’t possible. No xml-file was written. Log is showing an error: Specific device class 10 not found. I’m not sure but I gues the commentet lines are not correct.

[rialmessage.IdentifyNodeMessageClass] - NODE 9: ProtocolInfo
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Listening = false
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Routing = true
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Beaming = true <— battery powered?
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Version = 4
[rialmessage.IdentifyNodeMessageClass] - NODE 9: FLIRS = true
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Security = false <— secured communication shall be possible
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Max Baud = 40000
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Basic = Routing Slave
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Generic = Entry Control
[rialmessage.IdentifyNodeMessageClass] - NODE 9: Specific device class 10 not found

What can I do to use that door opener module.

If no XML is written by the binding, then please get a debug log so we can find out why…

log file you can find here:


I did notice I can include that device more than one time on the same controller without eclusion. How can that be?

Thanks. I’ll take a look at this tomorrow hopefully - from the quick look I’ve had I think I know the issue and it shouldn’t be too hard to resolve.

I’m not sure about the re-inclusion question. This might be normal - it’s not something I’ve tried, but I know it’s possible to get the same device showing up twice, so I suspect it’s the same issue… I’d suggest not to do this ;).

You shouldn’t need to keep excluding and re-including it though - once should be enough…

That sounds nice Chris,

I did try to include. I did press the button 3 times … nothing was shown… i did press agin 3 times … 2 new nodes was shown . I can’t remove the first one now.

To remove the first one, you can try the following (no guarantees though - especially for battery devices where it’s problematic to get rid of such devices)…

  1. In HABmin, select advanced mode - in the thing config screen, click on a thing, then click on the menu in the top right corner.

  1. Add the node that you want to get rid of as a thing - I assume it’s in your inbox at the moment?

  2. Select the Set device as FAILed, then Remove device from controller.

  1. Delete the thing.

Hopefully this will work, but the problem is that if the controller thinks the device might still be alive, then it won’t allow it to be removed. For battery devices, it can be especially problematic…

Good luck :wink:

Exactly that did I try allready. No luck. Can’t remove. So it will be an entry inside the inbox I’ve to ignore.

Let me know if the latest version works better - if no XML is produced still, then please provide a new log…

Thanks Chris. It works now. I have an xml file. Pls add to database.


It was the unknown class 10 right?

Yes - this is a new device class. In the development version I have all classes as defined in the zwave doc, but it’s no in the current version…

I’ll try and update this tonight.

Chris, I can’t use it until now. What’s the state?

Sorry - I missed this in the last database update. I’ll do another update tonight or tomorrow.

Hmm - I guess that since this is a lock controller, it needs the security classes which are not currently supported, so the database update won’t help much - sorry. Hopefully security will be added very soon…

Also, the database needs the configuration parameters adding, so it might be good if you can take a look at this?


I asked the Popp support. This xml they did send back:


looks the most is secured.


Yep - as expected for a lock…

Unfortunately that means it won’t currently work even with the database update. I’m hoping to get a test version which includes security available in the coming week or so.

I did notice, you did use the holliday to do something. Thats nice. I can check first in some days. I did kill the board while starting the test with the input. So I’ve to wait until I have a new one.

I also have one of these boards.

Does anyone have any idea how to manipulate the ‘sensors’ to activate/deactivate the lock?

As stated above - it’s not possible at the moment as the binding doesn’t support security.

So just asking, OH2 has no capability to add zwave devices securely?

That’s correct - this is not currently possible right now. It is in the development version, which will hopefully be available for widespread testing very soon, but it will likely be a while before it’s in the master branch.