Popp Radiator termostat - 010101 Wireless Thermostatic Valve TRV

This comes up as an unknwon device on openhab2 - havent tried openhab1. Any tips how to get it to work?
010101 Wireless Thermostatic Valve TRV

I have the Supported and controlled Z-wave command classes at a manual paper that came together with the unit, so I might be able to add it to the database myself - if someone gives me instructions how to do it.

Please ensure you’re using the latest version of the binding as this was added recently.


If you are using the latest version then please supply the XML generated by OH2 for this device.

Thanks for very quick reply!
I have Z-Wave Binding
binding-zwave - 2.0.0.b4

Where do I donate to the openhab project?

I have incluede experimental additions enabled.

This is the beta version from a few months back so it won’t include this device - you should change to use the latest snapshot of the complete runtime which you can get here -:


I’m not sure if there’s a one off donation possibility, but you can join the OH foundation which helps to support OH -:


Had to install the apt-get install apt-transport-https and then I try to add the line mentioned here (Openhab2 stable or beta?) -


However it gives error:
E: Type ‘https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo/’ is not known on line 4 in source list /etc/apt/sources.list

Also tried the:
sudo add-apt-repository https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo/

aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Raspbian/jessie

I guess this cloudbees.com is not intended to be used this way and have to be manually downloaded and unpacked. I`ll look into it tomorrow.

Sorry, my mistake - found this one which I used: http://docs.openhab.org/installation/linux.html#package-repository-installation -

Also found this :APT snapshot installation notice

dpkg -s openhab2-online | grep Version
Says; Version: 2.0.0~20161107032914

However the Thing-search still says:
Unknown device:

Have tried restarting the server. will try more tomorrow - bed now

Hm, do I need to remove and add the new thing again, since it was added with the old version of openhab2 - or does openhab2 search the new database. I can see the thing is listed on the about screen of the Z-Wave binding - so it should be there.

010101 Popp Wireless Thermostatic Valve TRV
Popp Wireless Thermostatic Valve TRV
Inclusion Information
Short push middle button

Wakeup Information
Short push middle button

Why is it called zwave:danfoss_010101_00_000
And not zwave:popp_010101_00_000

By the way?

Yes - just delete the thing, and add it back again - there’s no need to actually exclude the device from the network and add it back. Doing this will update the thing configuration from the latest XML.

Because that’s how the device identifies itself. It’s made by Danfoss (as is the Danfoss, and Devolo devices that look the same), not Popp.

Still no luck after deleting it and searching for it in paper-ui again.

Can you post the XML that the binding generates for this device please.

It does not seem to store any xml for that node in /var/lib/openhab2/zwave/ - however it stores for the other items - am i looking in the wrong folder?

Yes - that’s the right place.

If it’s not generating an XML, then either there’s a problem, or, you’ve not woken the device up - it’s a battery device, so it does need manual intervention…

1 Like

Noob! Had to do the following:

  • Add Unknown device in Paper UI
  • THEN wake up device with pushing the middle button
  • THEN it would find the correct item

I was assuming you had to:

  • THEN wake up device with pushing the middle button
  • THEN it would find the correct item
  • Add Unknown device in Paper UI

It seems other devices had this procedure.

It works now - great!

1 Like