Possible New Firmware version for Kwikset Z-Wave Lock - Needs Update

It seems there’s a new Firmware version of the Kwikset (Black & Decker) 910 Smart Lock, and I’ve got it. At least that’s my best guess.
As a result, the device, which is in the database, isn’t recognized by the openHAB Z-Wave binding.

Here’s the full Z-Wave ID of the device I have:
And the device in the database:
0090:0003:0238:4.034 ?

EDIT: Realizing that protocol and firmware are different and distinct. I noticed the following in the XML generated when the device was created:


Notice that the listing in the database here has a protocol version of 4.034 listed, while my device states “4.34”.

After reading the guide, you suggest to contact you via the forum to figure out the best way to get this device updated. To avoid causing any harm, I figured I’d tag you here @chris.
Any assistance would be greatly appreciated, thanks!

As an update - I’ve removed and re-included the device and it refuses to identify a manufacturer, even though it seems to pull in the correct information in HabMIN.

I turned on Debug logging and captured the pairing process. Everything seems to have gone successfully except for the Thing Type. It’s paired securely.

23:09:05.481 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Unable to find thing type (0090:0003:0238:4.10)
23:09:05.483 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Controller status changed to ONLINE.
23:09:05.485 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Controller is ONLINE. Starting device initialisation.
23:09:05.496 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Updating node properties.
23:09:05.500 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:a31f21b7:node23' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
23:09:05.504 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:a31f21b7:node23' has been updated.
23:09:05.617 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Updating node properties. MAN=144
23:09:05.619 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:a31f21b7:node23' has been updated.
23:09:05.622 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Updating node properties. MAN=144. SET. Was 144
23:09:05.624 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Properties synchronised
23:09:05.732 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Update ASSOCIATION group_ZWaveAssociationGroup [index=1, name=Lifeline, profile1=0, profile2=1, associations=[node_1]]: Adding node_1
23:09:05.733 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:a31f21b7:node23' has been updated.
23:09:05.738 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Configuration synchronised
23:09:05.944 [DEBUG] [ave.internal.protocol.ZWaveController] - Event listener added.
23:09:05.946 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:a31f21b7:node23' has been updated.
23:09:05.951 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Initialising Thing Node...
23:09:05.953 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Polling intialised at 1800 seconds - start in 1031400 milliseconds.
23:09:05.955 [INFO ] [smarthome.event.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
23:09:05.957 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 23: Device initialisation complete.

The database entry does not need to be changed. It has no version number currently specified so is not version specific.

My best guess is that you are running an old binding as this device was only added very recently. Please use the latest snapshot - in fact, please use the snapshot from tomorrow to be sure it’s included as I’m not even 100% sure it’s in the current binding as it was only added in the past week.

Ok, interesting. I had been using your “beta” z-wave binding jar for the past year on the old version of this lock – it worked beautifully with openhab. I upgraded openhab to 2.4 release and it still worked fine. Then, my old lock finally broke, recently, and the warranty replacement is what I have now. Which doesn’t work (same binding). I figured it would work the same as the old one.

Do you mean the latest openhab snapshot or do you have a z-wave binding .jar I should install?

Thanks for your help.

I mean the latest snapshot - but I’d give it some time yet as I’m not 100% sure this device is in the current binding, and I’m waiting for CI to complete its checks before I merge the latest database update. Given CI is running very slow these days (taking 6 to 8 hours to do a build) it will likely be tomorrow before it’s merged and the snapshot build is available.

I’m familiar with slow CI builds :smiley:!
Alright, I’ll give it a try tomorrow. I assume I’ll need to exclude and re-include the lock.

Surprised the old database entry wasn’t picked up for this device.

No - you shouldn’t need to.

It’s not an old entry - it was just added in the past week or so which is why it’s not in the database (or not in the binding at least).


One point (just for info) - this is the same thing. In ZWave, major and minor versions are treated separately and are separated by the space. So in both cases its major version 4, and minor version 34.

I understand. But for the past year, it must have been picking up a different database entry when my old 910 was working great :confounded:

Ah, Makes sense! Thanks.

EDIT: I updated to today’s snapshot, and then re-paired the lock. It’s working successfully now. Thanks! Ignore the below.

@chris New binding is in from the snapshot - lock is successfully recognized. However, the Z-Wave commands for lock/unlock don’t seem to work.
They are “sent” by openhab, but no command is actually realized at the lock, nor can alarms be received.
Possible something new has to happen with the binding that I’m not aware of?

I’m have same / simular issue. I have a Kwiqset SmartCode 916 Touchscreen Electronic Deadbolt
that isn’t recognized by the openHAB Z-Wave binding. The Kwiqset 914 is in the database, which my lock is functionally identical to.
(https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/992) (The difference is touchscreen vrs dedicated buttons)

My lock (from HABmin):
Manufacturer 0090 Black & Decker
Type / ID 0642
Firmware Version 4.10

This lock is the whole reason i got into ZWave, and thus OpenHAB. Eventually i want to do actions based on which code opened that lock. I am able to set the codes, so it’s clearly communicating. But thats all i am able to do. I don’t understand why i can do that and am so limited on other fronts, but that is not important to me now.

Is there a way for me manually to configure the Thing / Item / Channels, or is waiting for the database update the only way to go.

I just started 2 weeks ago and have a few other ZWave devices and rules working :smiley:

I am in the steep part of the learning curve and I am not sure how to update to lastest snapshot.
Is that openhabian-config --> Apply Improvements --> Packages ?

thank you :smiley: -P

Please can you provide the type/id of the device so we an take a look at this compared to the ones in the database. Alternatively, if you’re unsure, please provide the XML file that OH has generated for the device.

this lock (with it’s type/id) is referenced in the text part of the database for the 914.
The configuration Parameter 35 is used as read-only to report the Unique ID of the lock type.
Released Board ID Unique ID
910 Z-wave (Legacy, FW 3.4) 0x00 0x00
912 Z-wave (Legacy, FW 3.2) 0x00 0x00
910 Z-wave 0x02 0x36
912 Z-wave 0x03 0x36
914 Z-wave 0x04 0x36
916 Z-wave 0x06 0x42

The type/id you list is not valid for the manufacturer information - it should be two numbers (type, and id). We need to know the manufacturer data - not the information related to a parameter as this is non standard and can’t be used for device identification.

As requested, can you provide the xml file as this should contain the data.

Took me a while to find. Pasted it into message, but it got messed up. Find it on my public website http://paulrother.com/network_e59e55c4__node_6.xml Thank you.


Does this firmware do anything new/different than the version that is already in the database? I don’t care so much if this is a different physical version (eg is a deadlock versus some other lock type) so long as the commands and features at ZWave level are the same?

If they are, we can simply add the new IDs - otherwise we’ll need to create a new entry.

Same internal firmware, 914 has hard buttons. 916 has a touch screen. 914 is better as it’s faster to enter entry code, but 916 will do better outside.


1 Like

thanks, i’ve been working at this with no results. I have not given up! First I updated to latest snapshot, openHAB 2.5.0 Build #1577. No change. Deleted the lock, added it back in, again no change, but my user codes are gone. Maybe database changes didn’t make it into snapshot. System was unreliable, which might be to all the stuff i’ve tried (learning) over the last few weeks. So started from scratch, and updated to snapshot 1577 first thing. Did a restore on my configuration, and it’s the same. (Which is a testimony to the backup/restore.) Next step will be starting over again, with fresh install, and most recent snapshot, and just installing the lock. I will need to reset the lock, and rediscovering it again, which is an ordeal since the lock is a minute walk away. If that fails, will let you know.