Power failure during upgrade - Pi 4 won't boot

Hey guys, need help please :frowning:

Last night i lost power whilst running an ‘apt upgrade’

when power was restored, the Pi4 wouldnt start

here’s a screen shot.

You may find more specific help on the Raspberry Pi Forums.

It looks like either the SD card has become corrupted or the firmware installed onto the SD Card has. The boot loader detects the card and a config file but isn’t able to find any of the firmware files so it is likely that the power down happened during their replacement.

1 Like

Did you try unplugging it for a couple of min and try again.

Do you have backup

yeah tried unplugging…no difference.
backups - not tested them but hopefully.

In case it helps anyone else, here’s what i found and did.

When i mounted the SD card in my windows laptop i found that the files reportedly missing were, not just those but almost all files. I downloaded and installed OH and installed on new SD card, copied all the files but not the folders into a folder on the laptop.

I inserted the original SD card in laptop and copied the files back onto the old SD card, but chose not to overwrite any files.

When i inserted the SD card into my Pi, it just worked as before.

I recommend getting a UPS. With something as light as the PI, you can run for hours after losing powers. I hooked up all my PIs and the router to the UPS and it saved me many times already.

1 Like