Preview and Beta: Amazon Echo Control

What happens when you try to link to that item?

Nothing happens.
Now I am trying to manually define things and items in the config files but no luck so far. I got the Thing id from discovery and copy and pasted that into my definition but its not working.

edit … Gave up with thing config file and tried to assign a manually created item to Paper UI thing. It does not liink

Switch AFirstPlug "A On/Off" { channel="amazonechocontrol:smartHomeDevice:account1:smartHomeDevice1:powerState" }

And there is no log why this fails?

@J-N-K, is this something you could consider implementing. It would really change the interaction between OH and Alexa considerably.

Best, Jay

I‘m happily reviewing a PR for that, but unfortunately I have too many other projects ATM.

Re: Sidewalk-enabled devices

Has anybody done anything with their TILE smart home devices within Alexa for OH?

Alexa devices are now basically a hot spot for all TILE devices (yours and anybody else’s) called SideWalk.

It would be nice if you coulud see the Tile Last Location as a data point with in OH.


A new feature is launching on your Echo device: Amazon Sidewalk.

Amazon Sidewalk is a shared network that helps devices work better. For example, if your device loses its wifi connection, Sidewalk can simplify reconnecting to your router and help set up new Echo devices. Sidewalk can also extend the coverage for Sidewalk-enabled devices, such as Ring smart lights and pet and object trackers, so they can stay connected and continue to work over longer distances.

When enabled, Sidewalk uses a small portion of your Internet bandwidth to provide these services to you and your neighbors. This setting will apply to all of your supported Echo and Ring devices that are linked to your Amazon account.


Best, Jay

I had a WAN connection issue last night. It’s hard to belive but the line count says my log filled up with more than 100,000 entries of which 99.9999% are from the amazon echo control binding.

As there is no will to reduce the verbose logging when the WAN is down I fixed it myself. I post here in case others are interested >>>>

I now have openHAB checking for WAN connectivity issues and if there is a WAN connection problem the Amazon echo control binding is automatically stopped with a rule. Now there are no longer pages and pages of errors from the binding in mylog :slight_smile: When the WAN connection is resolved the amazonechocontrol binding is automatically started again by rule.

So, now its easier to check the logs to see what the problem was.

1 Like

thanks for the great addon, i fully use it with my amazon.com account , but I wonder if its possible to direct it to amazon.co.jp … it doesn’t seem to go there to log on and i am unable. to access that account thru amazon.com

I upgraded to OH3 the other day and now I now longer have any channels to link for my SmartThings contact sensors. They are Zigbee attached through Echo Plus. In OH2.5 they partially showed up. I could see temperature.
This is how the Thing shows up in OH3.
UID: amazonechocontrol:smartHomeDevice:1cb8b6f8:3dba3e0d-136a-418e-adc6-4c0f66e9b858
label: Back Gate
thingTypeUID: amazonechocontrol:smartHomeDevice
configuration:
id: AAA_SonarCloudService_28:6D:97:00:01:11:0C:3C
bridgeUID: amazonechocontrol:account:1cb8b6f8

If I attach to one directly with Zigbee. I see all the options. Zigbee

Unfortunately with the distance I cannot connect these directly with Zigbee.

I like OH3, but have a few problems.
Thanks

UPDATE: I add a remote server to pickup the remote Zigbee devices. So this is no longer a concern.

Is there any way to test the 3.0 Binding on OH 2.5 ?
The 2.5.12 is giving me troubles with continuous switch from online - unknown.
The 3.0 (tested on windows with the same file based config) works great.

No way. OPenHaB changes too much between 2.5 and 3.0

Thanks for the feedback.
Do you mean that, in order to have a working binding, I have definitively to switch my raspberry to OH3 ?
My PI is a rev.B and I don’t know if OH3 will be working…
If you say that OH 2.5 will be no longer support I will make a try … :slight_smile:

I don‘t say 2.5.x is no longer supported. But there are. changes in 3.0 that can‘t be backported to 2.5.x. Others can. It depends. New features will only be available in 3.x.

1 Like

Sorry to cross post, but is anyone else getting these errors in the log file while running the amazon echo control binding? I’m running the latest 2.5.x binding.

280 x Active   x  80 x 2.5.12.202101240248     x openHAB Add-ons :: Bundles : Amazon Echo Control Binding

and here is the error I keep getting.

2021-01-28 14:42:17.510 [ERROR] [trol.internal.handler.AccountHandler] - refresh data fails with unexpected error

java.time.format.DateTimeParseException: Text '2021-01-29Tnull-08:00' could not be parsed at index 11

	at java.time.format.DateTimeFormatter.parseResolved0(DateTimeFormatter.java:1949) ~[?:1.8.0_222]

	at java.time.format.DateTimeFormatter.parse(DateTimeFormatter.java:1851) ~[?:1.8.0_222]

	at java.time.ZonedDateTime.parse(ZonedDateTime.java:597) ~[?:1.8.0_222]

	at java.time.ZonedDateTime.parse(ZonedDateTime.java:582) ~[?:1.8.0_222]

	at org.openhab.binding.amazonechocontrol.internal.handler.EchoHandler.updateNotifications(EchoHandler.java:1283) ~[?:?]

	at org.openhab.binding.amazonechocontrol.internal.handler.AccountHandler.lambda$4(AccountHandler.java:489) ~[?:?]

	at java.util.concurrent.CopyOnWriteArrayList.forEach(CopyOnWriteArrayList.java:891) ~[?:1.8.0_222]

	at java.util.concurrent.CopyOnWriteArraySet.forEach(CopyOnWriteArraySet.java:404) ~[?:1.8.0_222]

	at org.openhab.binding.amazonechocontrol.internal.handler.AccountHandler.refreshNotifications(AccountHandler.java:488) ~[?:?]

	at org.openhab.binding.amazonechocontrol.internal.handler.AccountHandler.refreshData(AccountHandler.java:585) ~[?:?]

	at org.openhab.binding.amazonechocontrol.internal.handler.AccountHandler.refreshAfterCommand(AccountHandler.java:830) ~[?:?]

	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_222]

	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_222]

	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:1.8.0_222]

	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:1.8.0_222]

	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]

	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]

	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]

any help would be appreciated.

Thanks,
Jerry

New Build Coming for 2.5.x

[amazonechocontrol] fix routines (backport) by J-N-K · Pull Request #9983 · openhab/openhab-addons (github.com)

Looks like the URL the binding calls for routines has changed on Amazon’s side.

I personally have noticed that some of my routines have completely stopped working.

Best, Jay

Indeed looks like routines now dont work…

So forgive me for asking a silly question, but can this be fixed? There is no new binding version so do I have to edit the files as per the thread above? I thought bindings were in .jar format so would need to be recompiled in order to make this change.

Any ideas please or is it a waiting game?

1 Like

Yes on the waiting game question, the new build for the 2.5.x JAR failed so the owners of the bug will need to address it.

https://ci.openhab.org/job/PR-openHAB-Addons/2437/

Best, Jay

Fix has been merged. Next 2.5.13 SNAPSHOT should contain the fix.

Happily found and set the fix from here:
https://community.openhab.org/t/limit-2000-failed-not-found/115696/8
Routines work perfectly again. Thank you very much! :grinning:

1 Like

Thank you! This fix was requested by the original developer of the binding @michi

EDIT - 03.04.2021

OFFLINE NOW → Here’s the direct down JAR URL → https://janessa.me/esh/org.openhab.binding.amazonechocontrol-2.5.13-SNAPSHOT.jar

NEW LOCATION → Dropbox - org.openhab.binding.amazonechocontrol-2.5.13-SNAPSHOT.jar - Simplify your life

@Kai

The actual 2.5.x build process on the Echo binding for bug fixes has been broken and nobody is addressing it so we have to go to 3rd party URL to get the fix now.

[amazonechocontrol] fix routines (backport) by J-N-K · Pull Request #9983 · openhab/openhab-addons (github.com)

PR-openHAB-Addons #2437 [Jenkins]

[amazonechocontrol] fix missing time (backport from 3.0) by J-N-K · Pull Request #10009 · openhab/openhab-addons (github.com)

PR-openHAB-Addons #2512 [Jenkins]

Best, Jay